summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2022-07-23 08:55:44 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2022-07-23 08:57:45 -0700
commit6ec3baaf3f7e733462a0a453863710884df472a2 (patch)
treecc87687704dde0ae58cfbef5847e41f6ec88c0a1
parentdev-util/hermes: Forward ~riscv to 9999 (diff)
downloadgentoo-6ec3baaf3f7e733462a0a453863710884df472a2.tar.gz
gentoo-6ec3baaf3f7e733462a0a453863710884df472a2.tar.bz2
gentoo-6ec3baaf3f7e733462a0a453863710884df472a2.zip
dev-python/fdsend: re-add newer upstream version, needed for ganeti
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--dev-python/fdsend/Manifest1
-rw-r--r--dev-python/fdsend/fdsend-0.3.0.ebuild30
-rw-r--r--dev-python/fdsend/files/fdsend-0.3.0-2to3.patch12
-rw-r--r--dev-python/fdsend/metadata.xml13
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/fdsend/Manifest b/dev-python/fdsend/Manifest
new file mode 100644
index 000000000000..80c8c0ec7b23
--- /dev/null
+++ b/dev-python/fdsend/Manifest
@@ -0,0 +1 @@
+DIST fdsend-0.3.0.tar.gz 14988 BLAKE2B dc80885a4f69bc00bf02ba64377b3638354685d3f5290376bc808916f4bd912293d39babe7dbd27b04d0580823734403ac01033ca89423d7803c79bab827864e SHA512 f3b9ad3f74439f10e6938672a6d391ac33298f49cc32e14bbaf1c1efc7ebfae09b2ac5d73296dae3085c2da5debeb7ad50d9591c50c42dd5f584b138f3bb4bb6
diff --git a/dev-python/fdsend/fdsend-0.3.0.ebuild b/dev-python/fdsend/fdsend-0.3.0.ebuild
new file mode 100644
index 000000000000..5b2f60ab4cf6
--- /dev/null
+++ b/dev-python/fdsend/fdsend-0.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9,10,11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="flexible file descriptor passing"
+HOMEPAGE="https://github.com/fknittel/python-fdsend/"
+SRC_URI="https://github.com/fknittel/python-fdsend/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+DEPEND+=" test? ( dev-python/unittest-or-fail )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}/python-${P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.0-2to3.patch
+)
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ 2to3 . || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/fdsend/files/fdsend-0.3.0-2to3.patch b/dev-python/fdsend/files/fdsend-0.3.0-2to3.patch
new file mode 100644
index 000000000000..5645a31da001
--- /dev/null
+++ b/dev-python/fdsend/files/fdsend-0.3.0-2to3.patch
@@ -0,0 +1,12 @@
+Newer setuptools dropped 2to3 support, so let's call it in the ebuild instead.
+--- a/setup.py
++++ b/setup.py
+@@ -7,8 +7,6 @@ try:
+ setupopts = {
+ 'test_suite':"fdsend.tests",
+ }
+- if sys.version_info >= (3,):
+- setupopts['use_2to3'] = True
+ except ImportError:
+ from distutils.core import setup
+ setupopts = {}
diff --git a/dev-python/fdsend/metadata.xml b/dev-python/fdsend/metadata.xml
new file mode 100644
index 000000000000..54f73721b65e
--- /dev/null
+++ b/dev-python/fdsend/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>infra@gentoo.org</email>
+ <name>Gentoo Infrastructure Team</name>
+ </maintainer>
+ <!-- dependency for app-emulation/ganeti, used by infra -->
+</pkgmetadata>