summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-06 18:12:05 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-06 22:23:18 +0100
commit6eee0ee18be6818acb4d8a6e1f7cb18799c0f006 (patch)
tree05c00140808269349a522da6a9c2db7a6b24de35
parentsys-libs/libomp: Bump to 11.0.1 (final) (diff)
downloadgentoo-6eee0ee1.tar.gz
gentoo-6eee0ee1.tar.bz2
gentoo-6eee0ee1.zip
sys-devel/clang-runtime: Bump to 11.0.1 (final)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/clang-runtime/clang-runtime-11.0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-runtime/clang-runtime-11.0.1.ebuild b/sys-devel/clang-runtime/clang-runtime-11.0.1.ebuild
new file mode 100644
index 000000000000..961a678da4d2
--- /dev/null
+++ b/sys-devel/clang-runtime/clang-runtime-11.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-build
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="metapackage"
+SLOT="$(ver_cut 1-3)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~sys-libs/compiler-rt-${PV}:${SLOT}
+ sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
+ )
+ libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"