summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2019-11-17 16:03:33 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2019-11-17 18:11:51 +0300
commit6eef4b9abf6c40d524b44d604ca6ecaa9feb715f (patch)
tree6a39b1ba3af63f1fe3a40c8e13835ea7854b9381
parentdev-python/GridDataFormats: Add py3.7 (diff)
downloadgentoo-6eef4b9a.tar.gz
gentoo-6eef4b9a.tar.bz2
gentoo-6eef4b9a.zip
dev-python/netcdf4-python: Add py3.7 and move to eapi7
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
-rw-r--r--dev-python/netcdf4-python/netcdf4-python-1.2.2-r1.ebuild (renamed from dev-python/netcdf4-python/netcdf4-python-1.2.2.ebuild)8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/netcdf4-python/netcdf4-python-1.2.2.ebuild b/dev-python/netcdf4-python/netcdf4-python-1.2.2-r1.ebuild
index 402a7bc65f0e..4494e2f43bc5 100644
--- a/dev-python/netcdf4-python/netcdf4-python-1.2.2.ebuild
+++ b/dev-python/netcdf4-python/netcdf4-python-1.2.2-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit distutils-r1
@@ -23,7 +23,9 @@ RDEPEND="
dev-python/numpy
sci-libs/hdf5
sci-libs/netcdf:=[hdf,hdf5]"
-DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+RESTRICT="!test? ( test )"
S="${WORKDIR}"/${MY_P}