summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-29 02:35:47 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-29 02:36:10 +0200
commit6ef7c69333e13ef4d5369b0dde81216aa05a14b5 (patch)
tree72611df55546b3cafbf05a6daeda2ea8f5ddd254
parentsys-kernel/linux-firmware: don't use upstream tags (diff)
downloadgentoo-6ef7c693.tar.gz
gentoo-6ef7c693.tar.bz2
gentoo-6ef7c693.zip
media-sound/bluez-alsa: Added systemd unit file
Thanks-to: Chris Mayo <aklhfex@gmail.com> Closes: https://bugs.gentoo.org/677928 Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--media-sound/bluez-alsa/bluez-alsa-9999.ebuild3
-rw-r--r--media-sound/bluez-alsa/files/bluealsa.service10
2 files changed, 12 insertions, 1 deletions
diff --git a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
index cc7360650950..0e5b0d27ae84 100644
--- a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
+++ b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools multilib-minimal
+inherit autotools multilib-minimal systemd
DESCRIPTION="Bluetooth Audio ALSA Backend"
HOMEPAGE="https://github.com/Arkq/bluez-alsa"
@@ -58,6 +58,7 @@ multilib_src_install_all() {
newinitd "${FILESDIR}"/bluealsa-init.d bluealsa
newconfd "${FILESDIR}"/bluealsa-conf.d-2 bluealsa
+ systemd_dounit "${FILESDIR}"/bluealsa.service
}
pkg_postinst() {
diff --git a/media-sound/bluez-alsa/files/bluealsa.service b/media-sound/bluez-alsa/files/bluealsa.service
new file mode 100644
index 000000000000..12451ccb618c
--- /dev/null
+++ b/media-sound/bluez-alsa/files/bluealsa.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Bluetooth Audio ALSA Backend
+Requisite=dbus.service
+After=bluetooth.service dbus.service
+
+[Service]
+ExecStart=/usr/bin/bluealsa
+
+[Install]
+WantedBy=bluetooth.target