summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-06-27 10:20:26 +1200
committerKent Fredric <kentnl@gentoo.org>2020-06-27 10:20:43 +1200
commit6f06af2f3bb3f3c99be403bd492ff62720da084c (patch)
tree3ed096aa076a477cff4155dedebec436564c37ab
parentnet-nntp/sabnzbd: bump to v3.0.0_rc1 (diff)
downloadgentoo-6f06af2f.tar.gz
gentoo-6f06af2f.tar.bz2
gentoo-6f06af2f.zip
dev-perl/Compress-LZF: -r bump for EAPI7
- EAPI7 - Fix LICENSE - Ensure passing CFLAGS through to make Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Compress-LZF/Compress-LZF-3.800.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-perl/Compress-LZF/Compress-LZF-3.800.0-r1.ebuild b/dev-perl/Compress-LZF/Compress-LZF-3.800.0-r1.ebuild
new file mode 100644
index 000000000000..4c3508ba9f93
--- /dev/null
+++ b/dev-perl/Compress-LZF/Compress-LZF-3.800.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MLEHMANN
+DIST_VERSION=3.8
+inherit perl-module
+
+DESCRIPTION="extremely light-weight Lempel-Ziv-Free compression"
+# lzfP.h for BSD/GPL2+
+LICENSE="|| ( Artistic GPL-1+ ) || ( BSD-2 GPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}