summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-09 09:20:47 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-09 10:22:53 +0300
commit6f0e0028ab5e1b32c27ee00fb25f09f6e83904c7 (patch)
treeebb28499145b9282fc1204b350770a6666bf3bdc
parentdev-python/versioneer: add 0.26 (diff)
downloadgentoo-6f0e0028ab5e1b32c27ee00fb25f09f6e83904c7.tar.gz
gentoo-6f0e0028ab5e1b32c27ee00fb25f09f6e83904c7.tar.bz2
gentoo-6f0e0028ab5e1b32c27ee00fb25f09f6e83904c7.zip
dev-python/google-api-python-client: add 2.60.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.60.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 4953a9917801..dec66f37ecfc 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -2,3 +2,4 @@ DIST google-api-python-client-2.55.0.gh.tar.gz 32614590 BLAKE2B f7344903e4782940
DIST google-api-python-client-2.56.0.gh.tar.gz 33165501 BLAKE2B 5b4d72404f15c211cb01ca5291a74c83e9551b28c2e9e268462d481a3b05f557998fba8ed14c1233a023f60813be5b702f88371d47499a18cef152a52577f2ce SHA512 3ea968d11eda34d7807469c1651e8685ae695faed2772acbb23964468fa0cf9036fe468f427cd3f5bccd7c69746729858838446cbd320f0db7edff4add554d81
DIST google-api-python-client-2.57.0.gh.tar.gz 33298709 BLAKE2B 6c50bdcfc38180ece5f8202b0f3adcfc446cc0b057122aee7f706401248b7d860d9227c444b26faea49de5e4147010765edc5e54271907f6490e6f0d9fe0ac1e SHA512 f96c40b21f4191e5a06a4068b65c952d9d2bef3849a6aa821232c60dfc8b6c6598606b596c750cc87928871367cbbcb24af46b5626d602915ccf7a7f316988ba
DIST google-api-python-client-2.58.0.gh.tar.gz 33498127 BLAKE2B c00ecad1e863e5abb92cfbbbf57778b63ceaf73ae4cfb00ddf4fd0ed31656a28e475b91a02c03a6231790c2f3ab3e3243d131a97ed0f51151946568f5b56e18c SHA512 00c1606fadb46a6f4f60939135e9fd2840b267cd962630e4cd2d123588e9bdc8c0ed397d9e038ae91a2f31b732eb7698476fc1cf2322771b5720c11a97321b00
+DIST google-api-python-client-2.60.0.gh.tar.gz 33586321 BLAKE2B 01bb4dcf8a9b90a65c4e58ded91a7c03c525c15d29dc5b63011e1d1b8281ea68c04526af29d7853f4b7e16681c2482970f3b95faa190522ddf2f0ad3dd4e5e50 SHA512 7cae2e66ae7a41d25e551a5e9b14757d62c0212fe18640b4c1b8f51ff9e0150cfb9a2492de67530c7d24d6d09231d365520c3c06ffb342ba4a68a1a07b69b27d
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.60.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.60.0.ebuild
new file mode 100644
index 000000000000..7e8aaa05d6d4
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.60.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+SRC_URI="
+ https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}