summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-24 21:44:53 +0000
committerSam James <sam@gentoo.org>2020-10-25 19:11:49 +0000
commit6f348cb1f463b8ef951fdc0a4f06102e616334b6 (patch)
tree32e923792697bbb9ed75c7942d21fca71a6481d8
parentmedia-gfx/iscan-plugin-gt-f500: port to EAPI 7 (diff)
downloadgentoo-6f348cb1f463b8ef951fdc0a4f06102e616334b6.tar.gz
gentoo-6f348cb1f463b8ef951fdc0a4f06102e616334b6.tar.bz2
gentoo-6f348cb1f463b8ef951fdc0a4f06102e616334b6.zip
media-gfx/iscan-plugin-gt-x770: port to EAPI 7
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild2
-rw-r--r--media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r3.ebuild47
2 files changed, 16 insertions, 33 deletions
diff --git a/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild b/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild
index 89786f1de276..d107dd8ad8ec 100644
--- a/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild
+++ b/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.2.ebuild
@@ -44,7 +44,7 @@ pkg_postinst() {
iscan-registry --add interpreter usb 0x04b8 0x0131 "${MY_LIB}/esci/libesci-interpreter-gt-f720 /usr/share/esci/esfw8b.bin" || die
elog
elog "Firmware file esfw8b.bin for Epson Perfection V300 PHOTO"
- elog "has been installed in /usr/share/esci and registered for use."
+ elog "has been installed in ${EROOT}/usr/share/esci and registered for use."
elog
}
diff --git a/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r3.ebuild b/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r3.ebuild
index 380f3d1e59ea..e876f9536887 100644
--- a/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r3.ebuild
+++ b/media-gfx/iscan-plugin-gt-x770/iscan-plugin-gt-x770-2.1.2.1-r3.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
-inherit rpm versionator multilib
+inherit rpm
-MY_PV="$(get_version_component_range 1-3)"
-MY_PVR="$(replace_version_separator 3 -)"
+MY_PV="$(ver_cut 1-3)"
+MY_PVR="$(ver_rs 3 -)"
DESCRIPTION="Epson Perfection V500 scanner plugin for SANE 'epkowa' backend"
HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
@@ -14,19 +14,16 @@ SRC_URI="
x86? ( https://dev.gentoo.org/~flameeyes/avasys/${PN}/${MY_PV}/${PN}-${MY_PVR}.i386.rpm )
amd64? ( https://dev.gentoo.org/~flameeyes/avasys/${PN}/${MY_PV}/${PN}-${MY_PVR}.x86_64.rpm )
"
+S="${WORKDIR}"
LICENSE="AVASYS"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-IUSE=""
-
DEPEND=">=media-gfx/iscan-2.21.0
!!<media-gfx/iscan-plugin-gt-x770-2.1.2.1-r2"
RDEPEND="${DEPEND}"
-S="${WORKDIR}"
-
QA_PREBUILT="/opt/iscan/esci/libesint7C.so*"
src_configure() { :; }
@@ -44,46 +41,32 @@ src_install() {
doexe "${WORKDIR}/usr/$(get_libdir)/iscan/"*
}
-pkg_setup() {
- basecmds=(
- "iscan-registry --COMMAND interpreter usb 0x04b8 0x0130 /opt/iscan/esci/libesint7C /usr/share/iscan/esfw7C.bin"
- )
-}
-
pkg_postinst() {
elog
elog "Firmware file esfw41.bin for Epson Perfection V500"
- elog "has been installed in /usr/share/iscan."
+ elog "has been installed in ${EROOT}/usr/share/iscan."
elog
- [[ -n ${REPLACING_VERSIONS} ]] && return
+ [[ -n "${REPLACING_VERSIONS}" ]] && return
# Needed for scanner to work properly.
- if [[ ${ROOT} == "/" ]]; then
- for basecmd in "${basecmds[@]}"; do
- eval ${basecmd/COMMAND/add}
- done
+ if [[ -z "${EROOT}" ]]; then
+ iscan-registry --add interpreter usb 0x04b8 0x0130 /opt/iscan/esci/libesint7C /usr/share/iscan/esfw7C.bin || die
else
ewarn "Unable to register the plugin and firmware when installing outside of /."
ewarn "execute the following command yourself:"
- for basecmd in "${basecmds[@]}"; do
- ewarn "${basecmd/COMMAND/add}"
- done
+ ewarn "iscan-registry --add interpreter usb 0x04b8 0x0130 /opt/iscan/esci/libesint7C /usr/share/iscan/esfw7C.bin"
fi
}
pkg_prerm() {
- [[ -n ${REPLACED_BY_VERSION} ]] && return
+ [[ -n "${REPLACED_BY_VERSION}" ]] && return
- if [[ ${ROOT} == "/" ]]; then
- for basecmd in "${basecmds[@]}"; do
- eval ${basecmd/COMMAND/remove}
- done
+ if [[ -z "${EROOT}" ]]; then
+ iscan-registry --remove interpreter usb 0x04b8 0x0130 /opt/iscan/esci/libesint7C /usr/share/iscan/esfw7C.bin || die
else
ewarn "Unable to de-register the plugin and firmware when installing outside of /."
ewarn "execute the following command yourself:"
- for basecmd in "${basecmds[@]}"; do
- ewarn "${basecmd/COMMAND/remove}"
- done
+ ewarn "iscan-registry --remove interpreter usb 0x04b8 0x0130 /opt/iscan/esci/libesint7C /usr/share/iscan/esfw7C.bin"
fi
}