summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-26 02:07:40 +0100
committerSam James <sam@gentoo.org>2022-10-26 11:54:16 +0100
commit6f36dd9f952c61a9246cf6a0a2c2f468f7aa6d9c (patch)
treed6a67a409e0317b69b87d4d85bb65618ea893d6e
parentapp-emulation/wine-staging: update wine-mono to 7.4.0 in live (diff)
downloadgentoo-6f36dd9f952c61a9246cf6a0a2c2f468f7aa6d9c.tar.gz
gentoo-6f36dd9f952c61a9246cf6a0a2c2f468f7aa6d9c.tar.bz2
gentoo-6f36dd9f952c61a9246cf6a0a2c2f468f7aa6d9c.zip
dev-ml/ocaml-augeas: add 0.6
Closes: https://bugs.gentoo.org/798039 Closes: https://bugs.gentoo.org/750209 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ml/ocaml-augeas/Manifest1
-rw-r--r--dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-flags.patch21
-rw-r--r--dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-ocaml-4.09.patch28
-rw-r--r--dev-ml/ocaml-augeas/ocaml-augeas-0.6.ebuild39
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-ml/ocaml-augeas/Manifest b/dev-ml/ocaml-augeas/Manifest
index 5384aa76d59c..d68bd91cd260 100644
--- a/dev-ml/ocaml-augeas/Manifest
+++ b/dev-ml/ocaml-augeas/Manifest
@@ -1 +1,2 @@
DIST ocaml-augeas-0.5.tar.gz 59908 BLAKE2B f9f51afa0aec82e95d7bd81811e93e10587f1f2c1905338c0bbe47de61d983c24c0e5ab77aff1ca319834bf2199040a482b453177fa3c774e24ab72c3a534c14 SHA512 dfbad89790c6b5ada0e1239d002cb61a56a15350b2687d0987e0c61108d905e0c03756c08db7a3121eac3966fbeed86500e6f3c3c416cea2b974d9f50b8adabf
+DIST ocaml-augeas-0.6.tar.gz 65180 BLAKE2B d9959e1fbf5ceafabeb76e697abc405c31cffc4e085138613fa067b6e5a482e1fb9fe28b24d90b819cd9531e09d46e6dc0babf1c63dce3170a217631d6eb2487 SHA512 e747f5c09d3821b41d98e3f12c8dfe9bb13a69d6ccaaf954f4bb33e8e4d9d62603ae26fe9f93f10b2705872526b1863a1c20e0c8a53858fdf60f8cb8cbf50b7a
diff --git a/dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-flags.patch b/dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-flags.patch
new file mode 100644
index 000000000000..931324e5046d
--- /dev/null
+++ b/dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-flags.patch
@@ -0,0 +1,21 @@
+http://git.annexia.org/?p=ocaml-augeas.git;a=patch;h=56c0602e972f1fae336198eb9587d71f1e36daff
+
+From 56c0602e972f1fae336198eb9587d71f1e36daff Mon Sep 17 00:00:00 2001
+From: "Richard W.M. Jones" <rjones@redhat.com>
+Date: Tue, 20 Aug 2019 15:06:57 +0100
+Subject: [PATCH] Use ocamlopt -g option.
+
+Originally from Fedora.
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -34,8 +34,8 @@ LIBS = @AUGEAS_LIBS@ @LIBXML2_LIBS@ @LIBS@
+
+ OCAMLCFLAGS = -g
+ OCAMLCPACKAGES =
+-OCAMLOPTFLAGS =
+-OCAMLOPTPACKAGES =
++OCAMLOPTFLAGS = $(OCAMLCFLAGS)
++OCAMLOPTPACKAGES = $(OCAMLCPACKAGES)
+
+ OCAMLDOCFLAGS = -html -sort
+
diff --git a/dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-ocaml-4.09.patch b/dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-ocaml-4.09.patch
new file mode 100644
index 000000000000..937f1bb9c799
--- /dev/null
+++ b/dev-ml/ocaml-augeas/files/ocaml-augeas-0.6-ocaml-4.09.patch
@@ -0,0 +1,28 @@
+http://git.annexia.org/?p=ocaml-augeas.git;a=commit;h=1cf5aef99b26a46529ca797547c0b49627fffe78
+https://bugs.gentoo.org/750209
+
+From 1cf5aef99b26a46529ca797547c0b49627fffe78 Mon Sep 17 00:00:00 2001
+From: "Richard W.M. Jones" <rjones@redhat.com>
+Date: Sat, 7 Dec 2019 11:08:54 +0000
+Subject: [PATCH] caml_named_value returns const value pointer in OCaml 4.09+
+
+--- a/augeas-c.c
++++ b/augeas-c.c
+@@ -86,7 +86,7 @@ static const int error_map_len = sizeof error_map / sizeof error_map[0];
+ static void
+ raise_error_and_maybe_close (augeas_t t, const char *msg, bool close_handle)
+ {
+- value *exn = caml_named_value ("Augeas.Error");
++ const value *exn = caml_named_value ("Augeas.Error");
+ value args[5];
+ const int code = aug_error (t);
+ const char *aug_err_msg;
+@@ -132,7 +132,7 @@ raise_error_and_maybe_close (augeas_t t, const char *msg, bool close_handle)
+ static void
+ raise_init_error (const char *msg)
+ {
+- value *exn = caml_named_value ("Augeas.Error");
++ const value *exn = caml_named_value ("Augeas.Error");
+ value args[5];
+
+ args[0] = caml_alloc (1, 0);
diff --git a/dev-ml/ocaml-augeas/ocaml-augeas-0.6.ebuild b/dev-ml/ocaml-augeas/ocaml-augeas-0.6.ebuild
new file mode 100644
index 000000000000..86d56ae426d5
--- /dev/null
+++ b/dev-ml/ocaml-augeas/ocaml-augeas-0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit findlib
+
+DESCRIPTION="Ocaml bindings for Augeas"
+HOMEPAGE="http://augeas.net/"
+#SRC_URI="http://augeas.net/download/ocaml/${P}.tar.gz"
+SRC_URI="https://people.redhat.com/~rjones/augeas/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ app-admin/augeas
+ dev-libs/libxml2
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-ml/findlib
+ dev-ml/ocaml-autoconf
+ dev-lang/ocaml[ocamlopt]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${P}-ocaml-4.09.patch
+)
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+}