summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 13:59:01 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:18:01 +0100
commit6f5fc2c6210fc7a5b12b1367cf12a9cd14d94732 (patch)
tree6f8f04ec5261b9439d5c415dcb1b9d92d9a79e24
parentdev-python/uranium: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-6f5fc2c6.tar.gz
gentoo-6f5fc2c6.tar.bz2
gentoo-6f5fc2c6.zip
dev-ruby/pygments_rb: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-ruby/pygments_rb/pygments_rb-1.2.1-r1.ebuild (renamed from dev-ruby/pygments_rb/pygments_rb-1.2.1.ebuild)8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-ruby/pygments_rb/pygments_rb-1.2.1.ebuild b/dev-ruby/pygments_rb/pygments_rb-1.2.1-r1.ebuild
index 1e51b2fb94b3..23f293301191 100644
--- a/dev-ruby/pygments_rb/pygments_rb-1.2.1.ebuild
+++ b/dev-ruby/pygments_rb/pygments_rb-1.2.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,8 +30,10 @@ RUBY_S="${MY_P}"
RDEPEND+="
${PYTHON_DEPS}
- >=dev-python/pygments-2.2.0[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '
+ >=dev-python/pygments-2.2.0[${PYTHON_MULTI_USEDEP}]
+ dev-python/simplejson[${PYTHON_MULTI_USEDEP}]
+ ')"
DEPEND+=" test? ( ${RDEPEND} )"
ruby_add_rdepend ">=dev-ruby/multi_json-1.0.0"