summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-15 21:52:47 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-15 22:26:02 +0200
commit6f6546e3e9abd13ed9bf4685183a72f213d946f4 (patch)
tree16e610217de2adc19c665c6893f3daff698d46ea
parentdev-python/requests-cache: Bump to 0.8.1 (diff)
downloadgentoo-6f6546e3.tar.gz
gentoo-6f6546e3.tar.bz2
gentoo-6f6546e3.zip
dev-python/Faker: Bump to 8.13.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/Faker/Faker-8.13.2.ebuild29
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-8.13.2.ebuild b/dev-python/Faker/Faker-8.13.2.ebuild
new file mode 100644
index 000000000000..12e618b6e887
--- /dev/null
+++ b/dev-python/Faker/Faker-8.13.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="https://github.com/joke2k/faker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/text-unidecode-1.3[${PYTHON_USEDEP}]
+ !dev-ruby/faker"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 5ecddc1878cb..3af16bf3a842 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1,2 +1,3 @@
DIST Faker-8.12.0.tar.gz 1151218 BLAKE2B b55d1b1bac6a580c51fdd3f87919cbcea107aff309bce4d2092ec77046dc40c67650f3c53d176147b6b433008e7487dae9e096eb9ba6c8722ec54ce5d6d39449 SHA512 5df90c0976cb8b5e96f4c6645a984e813130fd22f25b5fb99b7cd28b6e079eec54b19f8ca643b795be15f41b9f5b677e89db1379615479983f0b5519a6dd56b4
DIST Faker-8.12.1.tar.gz 1151131 BLAKE2B fd59a337ed95429b34b2f9c1530a9db6ef4ec921d1c194e90e794ea6316fd8c79b8f2aa416ad8806cd2f4c31cca8d1d2cf60209a6bb4a75a708345a0bfb0a572 SHA512 e359b015d4908130b12ca6dd8c7e4801011de383eececb62f3ac76cb621cad1c9a873c5de989932405f7a30b33aef8969fb9788a331620db3d6c3ad1e5a657c4
+DIST Faker-8.13.2.tar.gz 1162423 BLAKE2B 595bac7a9a3031a46342ff19cfc1ef89bd7a5267dad3b1a18bda5cb3d96168eb0fda03adab940d35e499771ac1fc78e837631fe048fc374e0dcdcb62ac0a2002 SHA512 7da38c7bcf7b1b7364161092a38a2a9624ede6fed6e0bd9c8aec7acff83d4377bfef3e3ce2af48ea04d37eed0e880357bd40bca6eb81d19cdb876d66de249b04