summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-02-25 22:08:53 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-02-25 22:08:53 +0100
commit6f658a43323965a08dfbca81e332ff514664e8df (patch)
tree27b94e352c4510ffaf938f2102af58478a91a4a6
parentsys-apps/fwupd: Bump to version 1.2.5 (diff)
downloadgentoo-6f658a43.tar.gz
gentoo-6f658a43.tar.bz2
gentoo-6f658a43.zip
sys-fs/ddrescue: Bump to version 1.24
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-fs/ddrescue/Manifest1
-rw-r--r--sys-fs/ddrescue/ddrescue-1.24.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-fs/ddrescue/Manifest b/sys-fs/ddrescue/Manifest
index 1549c92fa647..82e827819713 100644
--- a/sys-fs/ddrescue/Manifest
+++ b/sys-fs/ddrescue/Manifest
@@ -1,3 +1,4 @@
DIST ddrescue-1.21.tar.lz 74716 BLAKE2B 0f50c05d20ad74dc7b3d1db5038f6707b0d2a569d880af24a8623712dc89e207faac096031a43de10acec66a1e862049b726de3c05f30c51232817a56fc5643d SHA512 6b8fddc621af90acc90e54c8688ea5d18721ea922b4433f2ed76f44bbaf5bd90b560b380c02a133fa7f67da85436d058861820eeeb46bbb7d3ef53821c0de079
DIST ddrescue-1.22.tar.lz 80050 BLAKE2B c455bf847749dc29565d02efef8b24f1a322e8069b51821ef9ebf7f6bbc650241ad76dadaf60e7daf92c55c2ae9e7d27b107e734404538e78678e1f2ac147e97 SHA512 3e5236374e2c1baae40026f59cf7040414d798a48d4edd6c6bde919e658ca958a795421301439ab2b8aa9f1d8fc60a2fff84b26e22a350e4150850b9830ce754
DIST ddrescue-1.23.tar.lz 82451 BLAKE2B ed9d71894d4c8466e3ca56d853ae5a6c4f7cf1955bea4468c158674e7bf6386343ab8289714be7ebb6b326f462e53fc7e9d8122a26079267ab4324f60c8fc4b8 SHA512 4f0b27067966b71efaae809d4f38714863cf3663f3b8c3f26055d482debb15c0fab77752411a9d242f18dbb8e4edc68494f866721dae9c95cfc5354439eaa656
+DIST ddrescue-1.24.tar.lz 85244 BLAKE2B e8b5ca5c89a65bed6126737125d78b2af9cdd7fe9b20f1f03636d58249d33dc08cb1907eca35c35d3ff81dd031290177084ae5dcc1cac20e79cb6c182cb894e4 SHA512 2c6a86c80bad122e0c44d6f8da49239e10362fbfbdb70acf39055ce02637daa05cce4f24adac732a1bb3a6fc97cf6985dd20827e99ab3bf6bad4db015a00fbaa
diff --git a/sys-fs/ddrescue/ddrescue-1.24.ebuild b/sys-fs/ddrescue/ddrescue-1.24.ebuild
new file mode 100644
index 000000000000..692566cd46ed
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.24.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs flag-o-matic unpacker
+
+DESCRIPTION="Copy data from one file or block device to another with read-error recovery"
+HOMEPAGE="https://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="static"
+
+DEPEND="$(unpacker_src_uri_depends)"
+RDEPEND=""
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # not a normal configure script
+ econf \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ ./testsuite/check.sh "${S}"/testsuite || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man
+ einstalldocs
+}