summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2023-11-26 08:47:04 +0000
committerMatthew Smith <matthew@gentoo.org>2023-11-26 08:49:37 +0000
commit6f99bb9cd86865404f652a895b835c862df04af9 (patch)
treeb3f85484206b96a9145b2a9e7a5a53c2e8cd7e5b
parentkernel-build.eclass: copy module signing key to tempdir in pkg_setup (diff)
downloadgentoo-6f99bb9cd86865404f652a895b835c862df04af9.tar.gz
gentoo-6f99bb9cd86865404f652a895b835c862df04af9.tar.bz2
gentoo-6f99bb9cd86865404f652a895b835c862df04af9.zip
net-mail/mu: install elisp site file
Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--net-mail/mu/mu-1.10.7-r1.ebuild (renamed from net-mail/mu/mu-1.10.7.ebuild)10
-rw-r--r--net-mail/mu/mu-1.10.8-r1.ebuild (renamed from net-mail/mu/mu-1.10.8.ebuild)10
2 files changed, 14 insertions, 6 deletions
diff --git a/net-mail/mu/mu-1.10.7.ebuild b/net-mail/mu/mu-1.10.7-r1.ebuild
index 2acec2e5ddb5..f637744311ea 100644
--- a/net-mail/mu/mu-1.10.7.ebuild
+++ b/net-mail/mu/mu-1.10.7-r1.ebuild
@@ -61,9 +61,13 @@ src_install() {
docompress -x /usr/share/doc/${PF}/NEWS.org
dodoc NEWS.org
- # Same as above.
- docompress -x /usr/share/doc/${PF}/mu4e-about.org
- dodoc mu4e/mu4e-about.org
+ if use emacs; then
+ # Same as above.
+ docompress -x /usr/share/doc/${PF}/mu4e-about.org
+ dodoc mu4e/mu4e-about.org
+
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
}
pkg_preinst() {
diff --git a/net-mail/mu/mu-1.10.8.ebuild b/net-mail/mu/mu-1.10.8-r1.ebuild
index 2acec2e5ddb5..f637744311ea 100644
--- a/net-mail/mu/mu-1.10.8.ebuild
+++ b/net-mail/mu/mu-1.10.8-r1.ebuild
@@ -61,9 +61,13 @@ src_install() {
docompress -x /usr/share/doc/${PF}/NEWS.org
dodoc NEWS.org
- # Same as above.
- docompress -x /usr/share/doc/${PF}/mu4e-about.org
- dodoc mu4e/mu4e-about.org
+ if use emacs; then
+ # Same as above.
+ docompress -x /usr/share/doc/${PF}/mu4e-about.org
+ dodoc mu4e/mu4e-about.org
+
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
}
pkg_preinst() {