summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-26 03:35:40 +0100
committerSam James <sam@gentoo.org>2021-07-26 03:35:40 +0100
commit6f9be85a1c760aca7c090ea244d563d7de3f248b (patch)
treeb4ccf6e5ffe54beb491e7cf591d1fa0189a07f49
parentdev-python/csv23: treeclean (diff)
downloadgentoo-6f9be85a.tar.gz
gentoo-6f9be85a.tar.bz2
gentoo-6f9be85a.zip
dev-python/brotlipy: treeclean
Bug: https://bugs.gentoo.org/796749 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/brotlipy/Manifest2
-rw-r--r--dev-python/brotlipy/brotlipy-0.7.0-r3.ebuild49
-rw-r--r--dev-python/brotlipy/files/brotlipy-0.7.0-test-deadline.patch28
-rw-r--r--dev-python/brotlipy/metadata.xml12
-rw-r--r--profiles/package.mask6
5 files changed, 0 insertions, 97 deletions
diff --git a/dev-python/brotlipy/Manifest b/dev-python/brotlipy/Manifest
deleted file mode 100644
index d8b0aa25bad2..000000000000
--- a/dev-python/brotlipy/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST brotli-46c1a881b41bb638c76247558aa04b1591af3aa7.tar.gz 19840371 BLAKE2B b9a1c3c2e5b62bd63b392debe54bd1732ac1cb31f88500f0142108b453649d96901d9a03b6db98642cb9abaf9188c06d440f2b8bd3cf57fbbb52196a931f5079 SHA512 dc573c90491032a205f32f0ce9c93e95b06c70a3107caa9501e038a212226c37117d63709a29843367344bf7d18cf32d0c0578b11166387198e12b38b1522406
-DIST brotlipy-0.7.0.tar.gz 19375 BLAKE2B 035dc8757e491bc4fc0d8e2b6b82703eecc8f6f4150da42fda0f6c6f42a617519f5191371eb1dd976b8bbfeab88845bb018b874a395cdbf0ff409a6911f969f5 SHA512 bec8183cf3cc8ba9e594d1a86a8a33d88a6ac8e9c6a6287c837bda3726183ff1b486f2c49da4e489b5b3cb51b57dd5816413b59419920c2ced48435221f1beaf
diff --git a/dev-python/brotlipy/brotlipy-0.7.0-r3.ebuild b/dev-python/brotlipy/brotlipy-0.7.0-r3.ebuild
deleted file mode 100644
index 9d1102eab848..000000000000
--- a/dev-python/brotlipy/brotlipy-0.7.0-r3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
-inherit distutils-r1
-
-# Commit of the Brotli library bundled within brotlipy.
-BROTLI_BUNDLED_COMMIT="46c1a881b41bb638c76247558aa04b1591af3aa7"
-
-DESCRIPTION="Python binding to the Brotli library"
-HOMEPAGE="https://github.com/python-hyper/brotlipy/ https://pypi.python.org/pypi/brotlipy"
-SRC_URI="
- https://github.com/python-hyper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://github.com/google/brotli/archive/${BROTLI_BUNDLED_COMMIT}.tar.gz -> brotli-${BROTLI_BUNDLED_COMMIT}.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-# module name collision with app-arch/brotli
-RDEPEND="
- virtual/python-cffi[${PYTHON_USEDEP}]
- !app-arch/brotli[python]"
-DEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/brotlipy-0.7.0-test-deadline.patch
-)
-
-src_prepare() {
- # Inject the brotli lib.
- rm -r "${WORKDIR}/${P}/libbrotli" || die "Could not remove the bundled brotli lib folder."
- cp -r "${WORKDIR}/brotli-${BROTLI_BUNDLED_COMMIT}/" "${WORKDIR}/${P}/libbrotli" || die "Could not inject the brotli lib."
-
- # Tests fail if we have this folder preserved within the lib.
- rm -r "${WORKDIR}/${P}/libbrotli/python" || die "Could not remove 'python' subfolder."
-
- distutils-r1_src_prepare
-}
diff --git a/dev-python/brotlipy/files/brotlipy-0.7.0-test-deadline.patch b/dev-python/brotlipy/files/brotlipy-0.7.0-test-deadline.patch
deleted file mode 100644
index 219243986dd9..000000000000
--- a/dev-python/brotlipy/files/brotlipy-0.7.0-test-deadline.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff -dupr a/test/test_simple_compression.py b/test/test_simple_compression.py
---- a/test/test_simple_compression.py 2017-05-30 10:20:01.000000000 +0200
-+++ b/test/test_simple_compression.py 2019-11-22 11:37:31.248755016 +0100
-@@ -9,7 +9,7 @@ import brotli
-
- import pytest
-
--from hypothesis import given
-+from hypothesis import given, settings
- from hypothesis.strategies import binary, integers, sampled_from, one_of
-
-
-@@ -25,6 +25,7 @@ def test_roundtrip_compression_with_file
- ) == uncompressed_data
-
-
-+@settings(deadline=None)
- @given(
- chunk_size=integers(min_value=1, max_value=2**12),
- mode=sampled_from(list(brotli.BrotliEncoderMode)),
-@@ -62,6 +63,7 @@ def test_streaming_compression(one_compr
- assert decompressed == f.read()
-
-
-+@settings(deadline=None)
- @given(
- chunk_size=integers(min_value=1, max_value=2**12),
- mode=sampled_from(list(brotli.BrotliEncoderMode)),
diff --git a/dev-python/brotlipy/metadata.xml b/dev-python/brotlipy/metadata.xml
deleted file mode 100644
index 56e99b52ee7f..000000000000
--- a/dev-python/brotlipy/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">brotlipy</remote-id>
- <remote-id type="github">python-hyper/brotlipy</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index d7e3959e5b4d..b084859b76d6 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -388,12 +388,6 @@ dev-java/jibx-tools
# Removal on 2021-07-19. Bug #786279.
app-misc/rq
-# Michał Górny <mgorny@gentoo.org> (2021-06-19)
-# Conflicts with app-arch/brotli[python]. Discontinued in favor
-# of dev-python/brotlicffi. No revdeps remain.
-# Removal on 2021-07-19. Bug #796749.
-dev-python/brotlipy
-
# Mike Gilbert <floppym@gentoo.org> (2021-06-17)
# rescan-scsi-bus.sh is installed by >=sys-apps/sg3_utils-1.44, rendering
# this package redundant.