summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2017-12-23 00:46:36 +0100
committerCraig Andrews <candrews@gentoo.org>2018-01-05 18:52:46 -0500
commit6fa73c3cf9ca1a0ee739797af332cea10e6ae485 (patch)
tree70c13ff21eafbe4efb431731ecb75f96bf57af66
parentprofiles: More unused linguas_* removed from use.desc. (diff)
downloadgentoo-6fa73c3cf9ca1a0ee739797af332cea10e6ae485.tar.gz
gentoo-6fa73c3cf9ca1a0ee739797af332cea10e6ae485.tar.bz2
gentoo-6fa73c3cf9ca1a0ee739797af332cea10e6ae485.zip
dev-libs/spdlog: bump to 0.16.2
Unbundled libfmt and instead depend on dev-libs/libfmt
-rw-r--r--dev-libs/spdlog/Manifest1
-rw-r--r--dev-libs/spdlog/files/spdlog-unbundle-fmt.patch90
-rw-r--r--dev-libs/spdlog/spdlog-0.16.2.ebuild38
-rw-r--r--dev-libs/spdlog/spdlog-9999.ebuild7
4 files changed, 135 insertions, 1 deletions
diff --git a/dev-libs/spdlog/Manifest b/dev-libs/spdlog/Manifest
index fa22ebf74f6c..768810aa79e8 100644
--- a/dev-libs/spdlog/Manifest
+++ b/dev-libs/spdlog/Manifest
@@ -1,3 +1,4 @@
DIST spdlog-0.13.0.tar.gz 154551 BLAKE2B 1b20393a305ac020aa422b174d5b707bbffd8efb38708807e40a3a13d3483fe5c73ea8e47a5ded89e49b9699ab844b25ce7bff7fa07bd6f79212bdc9fc0afb64 SHA512 5bb89cbeb17a054832ce70f6013d54e7641c1aa36cbad08388b4a2e63f4851943edfe292551ff01de6de1ed6325617384325a67f3e1024f346c6d22a1148c80c
DIST spdlog-0.14.0.tar.gz 155590 BLAKE2B fb070e1049977ded34fef4953e743b7a3c4c745093e2d1974d0749f065799d6021046f5e913cee3b17e5ace9cdbd8a787532f7426ffc47bd8a7f1ab8d4fd4869 SHA512 f49b7f26f4fde57fe16f32ab89082f0c590645c627f5b4646f633a16f3eec2926b3465e742bc4899cb802e7b974978c547638205065e9955ed9696fbcaf0b444
DIST spdlog-0.16.1.tar.gz 162408 BLAKE2B c90b94bac128f8b143d85522d224223b1361f7d552d9caa8b253e494dd72de56a2149cbd8d568eb4305224d7caf80d8067fbce606a1071bd94f74c43b3245782 SHA512 0ef741f2abcae7c925808b44bba7d2e55aa8bd3b07a77ab6e785068beb505cdbcd7835d7d103e8e96094235e262954969a176d9f4977e9d373f1bee8e2716ff2
+DIST spdlog-0.16.2.tar.gz 162709 BLAKE2B 7cd031bd9b1e01aa11186334ada9aad50cdc063942e0eb5b9d36e918e305db4c0e5657a215f24f458dbf792e05c38f74409bc7f5f88049bd1c4a759ccab0167e SHA512 454da17d75fa6dae074fb2ef10d93a1f9ccbf23b625521d32ce463a1362411ffc35ca33b081bee3cfb27bb647472de73899c9a15d24f09c8a3c9222560bcf559
diff --git a/dev-libs/spdlog/files/spdlog-unbundle-fmt.patch b/dev-libs/spdlog/files/spdlog-unbundle-fmt.patch
new file mode 100644
index 000000000000..1b2449949bfe
--- /dev/null
+++ b/dev-libs/spdlog/files/spdlog-unbundle-fmt.patch
@@ -0,0 +1,90 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 52d2953..d132d26 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -80,6 +80,7 @@ install(
+ install(
+ DIRECTORY "${HEADER_BASE}/${PROJECT_NAME}"
+ DESTINATION "${include_install_dir}"
++ PATTERN "bundled*" EXCLUDE
+ )
+
+ # install project version file
+diff --git a/include/spdlog/fmt/fmt.h b/include/spdlog/fmt/fmt.h
+index 92ca4e5..55f1fa8 100644
+--- a/include/spdlog/fmt/fmt.h
++++ b/include/spdlog/fmt/fmt.h
+@@ -10,25 +10,7 @@
+ // By default spdlog include its own copy.
+ //
+
+-#if !defined(SPDLOG_FMT_EXTERNAL)
+-
+-#ifndef FMT_HEADER_ONLY
+-#define FMT_HEADER_ONLY
+-#endif
+-#ifndef FMT_USE_WINDOWS_H
+-#define FMT_USE_WINDOWS_H 0
+-#endif
+-#include "bundled/format.h"
+-#if defined(SPDLOG_FMT_PRINTF)
+-#include "bundled/printf.h"
+-#endif
+-
+-#else //external fmtlib
+-
+ #include <fmt/format.h>
+ #if defined(SPDLOG_FMT_PRINTF)
+ #include <fmt/printf.h>
+ #endif
+-
+-#endif
+-
+diff --git a/include/spdlog/fmt/ostr.h b/include/spdlog/fmt/ostr.h
+index 5cdd5cd..d70c6b3 100644
+--- a/include/spdlog/fmt/ostr.h
++++ b/include/spdlog/fmt/ostr.h
+@@ -7,11 +7,6 @@
+
+ // include external or bundled copy of fmtlib's ostream support
+ //
+-#if !defined(SPDLOG_FMT_EXTERNAL)
+-#include "fmt.h"
+-#include "bundled/ostream.h"
+-#else
+ #include <fmt/ostream.h>
+-#endif
+
+
+diff --git a/include/spdlog/tweakme.h b/include/spdlog/tweakme.h
+index ad01a09..9a1bec4 100644
+--- a/include/spdlog/tweakme.h
++++ b/include/spdlog/tweakme.h
+@@ -98,14 +98,6 @@
+ ///////////////////////////////////////////////////////////////////////////////
+
+
+-///////////////////////////////////////////////////////////////////////////////
+-// Uncomment to use your own copy of the fmt library instead of spdlog's copy.
+-// In this case spdlog will try to include <fmt/format.h> so set your -I flag accordingly.
+-//
+-// #define SPDLOG_FMT_EXTERNAL
+-///////////////////////////////////////////////////////////////////////////////
+-
+-
+ ///////////////////////////////////////////////////////////////////////////////
+ // Uncomment to use printf-style messages in your logs instead of the usual
+ // format-style used by default.
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 22329b4..44dad86 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -13,7 +13,7 @@ target_include_directories(catch INTERFACE ${CMAKE_CURRENT_SOURCE_DIR})
+ file(GLOB catch_tests LIST_DIRECTORIES false RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.cpp *.h *.hpp)
+
+ add_executable(catch_tests ${catch_tests})
+-target_link_libraries(catch_tests spdlog ${CMAKE_THREAD_LIBS_INIT})
++target_link_libraries(catch_tests spdlog fmt ${CMAKE_THREAD_LIBS_INIT})
+ add_test(NAME catch_tests COMMAND catch_tests)
+ file(MAKE_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/logs")
+
diff --git a/dev-libs/spdlog/spdlog-0.16.2.ebuild b/dev-libs/spdlog/spdlog-0.16.2.ebuild
new file mode 100644
index 000000000000..b22d880ad039
--- /dev/null
+++ b/dev-libs/spdlog/spdlog-0.16.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Very fast, header only, C++ logging library."
+HOMEPAGE="https://github.com/gabime/spdlog"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gabime/spdlog"
+else
+ SRC_URI="https://github.com/gabime/spdlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+ dev-libs/libfmt
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-unbundle-fmt.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DSPDLOG_BUILD_EXAMPLES=no
+ -DSPDLOG_BUILD_TESTING=$(usex test)
+ )
+
+ cmake-utils_src_configure
+
+}
diff --git a/dev-libs/spdlog/spdlog-9999.ebuild b/dev-libs/spdlog/spdlog-9999.ebuild
index 4c9cf2286540..b22d880ad039 100644
--- a/dev-libs/spdlog/spdlog-9999.ebuild
+++ b/dev-libs/spdlog/spdlog-9999.ebuild
@@ -20,9 +20,13 @@ LICENSE="MIT"
SLOT="0"
IUSE="test"
-DEPEND=""
+DEPEND="
+ dev-libs/libfmt
+"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-unbundle-fmt.patch" )
+
src_configure() {
local mycmakeargs=(
-DSPDLOG_BUILD_EXAMPLES=no
@@ -30,4 +34,5 @@ src_configure() {
)
cmake-utils_src_configure
+
}