summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-05-29 15:14:20 -0400
committerZero_Chaos <zerochaos@gentoo.org>2018-05-29 15:14:38 -0400
commit6fb408c56cf0aec0187cef4534b0974e6e140d7a (patch)
tree4b7828e75171569b46eae721134659e75f2c01a2
parentmedia-libs/libepoxy: DEPEND on virtual/libepoxy (diff)
downloadgentoo-6fb408c5.tar.gz
gentoo-6fb408c5.tar.bz2
gentoo-6fb408c5.zip
net-wireless/kismet: upstream re-broke setuptools
Package-Manager: Portage-2.3.38, Repoman-2.3.9
-rw-r--r--net-wireless/kismet/files/fix-setuptools.patch73
-rw-r--r--net-wireless/kismet/kismet-9999.ebuild1
2 files changed, 74 insertions, 0 deletions
diff --git a/net-wireless/kismet/files/fix-setuptools.patch b/net-wireless/kismet/files/fix-setuptools.patch
new file mode 100644
index 000000000000..a86f66b4447c
--- /dev/null
+++ b/net-wireless/kismet/files/fix-setuptools.patch
@@ -0,0 +1,73 @@
+commit e31263b50acd960f7bb0c34c0396383319d7da30
+Author: Rick Farina (Zero_Chaos) <zerochaos@gentoo.org>
+Date: Tue Apr 24 11:38:17 2018 -0400
+
+ make setuptools respect DESTDIR
+
+ thanks to mgorny for pointint it out
+
+diff --git a/capture_freaklabs_zigbee/Makefile.in b/capture_freaklabs_zigbee/Makefile.in
+index 75c85da9..980c417a 100644
+--- a/capture_freaklabs_zigbee/Makefile.in
++++ b/capture_freaklabs_zigbee/Makefile.in
+@@ -6,7 +6,7 @@ all:
+ $(PYTHON2) ./setup.py build
+
+ install:
+- $(PYTHON2) ./setup.py install
++ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
+ $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MONITOR_BIN) $(BIN)/$(MONITOR_BIN)
+
+ clean:
+diff --git a/capture_sdr_rtl433/Makefile.in b/capture_sdr_rtl433/Makefile.in
+index 23446edc..babc63f4 100644
+--- a/capture_sdr_rtl433/Makefile.in
++++ b/capture_sdr_rtl433/Makefile.in
+@@ -7,7 +7,7 @@ all:
+ $(PYTHON2) ./setup.py build
+
+ install:
+- $(PYTHON2) ./setup.py install
++ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
+ $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MONITOR_BIN) $(BIN)/$(MONITOR_BIN)
+ $(INSTALL) -o $(INSTUSR) -g $(INSTGRP) $(MQTTMONITOR_BIN) $(BIN)/$(MQTTMONITOR_BIN)
+
+diff --git a/python_modules/KismetExternal/Makefile b/python_modules/KismetExternal/Makefile
+index 036541a0..fc660dfe 100644
+--- a/python_modules/KismetExternal/Makefile
++++ b/python_modules/KismetExternal/Makefile
+@@ -4,7 +4,7 @@ all:
+ $(PYTHON2) ./setup.py build
+
+ install:
+- $(PYTHON2) ./setup.py install
++ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
+
+ protobuf:
+ $(PROTOCBIN) -I ../../protobuf_definitions --python_out=./KismetExternal ../../protobuf_definitions/*.proto
+diff --git a/python_modules/KismetLog/Makefile b/python_modules/KismetLog/Makefile
+index d0d6f784..60e1eac1 100644
+--- a/python_modules/KismetLog/Makefile
++++ b/python_modules/KismetLog/Makefile
+@@ -4,7 +4,7 @@ all:
+ $(PYTHON2) ./setup.py build
+
+ install:
+- $(PYTHON2) ./setup.py install
++ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
+
+ clean:
+ @-$(PYTHON2) ./setup.py clean
+diff --git a/python_modules/KismetRest/Makefile b/python_modules/KismetRest/Makefile
+index d0d6f784..60e1eac1 100644
+--- a/python_modules/KismetRest/Makefile
++++ b/python_modules/KismetRest/Makefile
+@@ -4,7 +4,7 @@ all:
+ $(PYTHON2) ./setup.py build
+
+ install:
+- $(PYTHON2) ./setup.py install
++ $(PYTHON2) ./setup.py install --root=$(DESTDIR)
+
+ clean:
+ @-$(PYTHON2) ./setup.py clean
diff --git a/net-wireless/kismet/kismet-9999.ebuild b/net-wireless/kismet/kismet-9999.ebuild
index 8005063ea995..2a6321ed5126 100644
--- a/net-wireless/kismet/kismet-9999.ebuild
+++ b/net-wireless/kismet/kismet-9999.ebuild
@@ -67,6 +67,7 @@ src_prepare() {
sed -i -e 's| -s||g' \
-e 's|@mangrp@|root|g' Makefile.in
+ epatch "${FILESDIR}"/fix-setuptools.patch
eapply_user
eautoreconf
}