summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-30 07:56:57 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-30 07:58:56 +0100
commit6fc398436c10a04b84f8e22d3edad36a35e78e76 (patch)
tree7dc8e41051ea54aacd67a54b728a48e9605d2957
parentdev-python/pytest-localserver: Bump to 0.7.1 (diff)
downloadgentoo-6fc39843.tar.gz
gentoo-6fc39843.tar.bz2
gentoo-6fc39843.zip
dev-python/xdoctest: Bump to 1.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/xdoctest/Manifest1
-rw-r--r--dev-python/xdoctest/xdoctest-1.1.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
index 438c02b95a3b..63b76f6d1cb0 100644
--- a/dev-python/xdoctest/Manifest
+++ b/dev-python/xdoctest/Manifest
@@ -1 +1,2 @@
DIST xdoctest-1.1.0.gh.tar.gz 208884 BLAKE2B cdba39e0e7108ddf7b637391dc549853754864d407b11c9237e9bc9988686bba2787e37892451bbdd3df4f7a2f01b0c446a658180c6ab06081b494313bbfe066 SHA512 55d3e58969414098a60fc4f825a8323c4e0de88e7f387fd93e61bd7c54fcebd76a66eff8d07850383009fce0e5c301838a051c886a45e4f1159e6210493a057c
+DIST xdoctest-1.1.1.gh.tar.gz 212973 BLAKE2B 2af66b23889ba1f0321af08fbb81cec87f6c582fe000eaa3372f166287bf69b40fd82eff1029aadb0d0d62760640881676f61571f0bed37309a98680450fbe77 SHA512 8b0f77df54be8e61bf1b98bbc6ef7ac76337e634ea590394e13481c61ea83b6b4b017588f8d6ab813f95d277f605ece2d82441d6cbd25bbf485dd5bc85677abd
diff --git a/dev-python/xdoctest/xdoctest-1.1.1.ebuild b/dev-python/xdoctest/xdoctest-1.1.1.ebuild
new file mode 100644
index 000000000000..2c7df196799c
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-1.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="
+ https://github.com/Erotemic/xdoctest/
+ https://pypi.org/project/xdoctest/
+"
+SRC_URI="
+ https://github.com/Erotemic/xdoctest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+# dev-python/nbformat-5.1.{0..2} did not install package data
+BDEPEND="
+ test? (
+ >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+#distutils_enable_sphinx docs/source \
+# dev-python/autoapi \
+# dev-python/sphinx_rtd_theme
+
+EPYTEST_DESELECT=(
+ tests/test_pytest_cli.py::test_simple_pytest_import_error_cli
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdoctest.plugin
+
+ epytest --pyargs tests xdoctest
+}