summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-30 11:48:18 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-30 12:32:45 +0300
commit6fd624169c2a208e44ce1671de9d92140111dbe4 (patch)
tree4240e675ef6679e6d1e5ae56f2fe8ed772e29649
parentdev-python/botocore: add 1.27.41 (diff)
downloadgentoo-6fd62416.tar.gz
gentoo-6fd62416.tar.bz2
gentoo-6fd62416.zip
dev-python/boto3: add 1.24.41
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.41.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index c706364b9664..6b912adb909c 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.24.31.gh.tar.gz 519387 BLAKE2B 8581d1018f0e1f0802779851edb52fdb6860
DIST boto3-1.24.36.gh.tar.gz 522156 BLAKE2B b76cb50f01ff85c960a0984f950e72f02ac6e85131fd344142b886a3c745cb8b9073f865527911b88c462912413fce6df4066752ab5eec8ad1561d349ad22437 SHA512 fe00e78cc522248c449f83f869bb7d76793db9aa436259e74d0aa25984a02876191a7df41b1ad7658b06e418f248ad616743698c87a5c9696f77a196a53c561e
DIST boto3-1.24.37.gh.tar.gz 522233 BLAKE2B ab361fd7443ff499c18a8e86c9a80da14e6a1d960fbac26d2e12d8806684daf169010225ce7a402626a814cb29fcc281ea61d293eb5eb197f48dccdb8a7a14ef SHA512 b75ea002f3a3e3b8c498797278adbf5f7d4b220baf7b8fa3be8c972bf2981933d962878b7d96a7c01c9a28be267effea34b48692716e7eabfa077ede380c816e
DIST boto3-1.24.40.gh.tar.gz 524303 BLAKE2B 750d366914ebbfaab262a88d96afb1df6f16c108e1e07537e0ae2234df95500c7dabaeae27afc5c5cbb8b0370b3a088b97c16a8c48e3d2f5741744841f29fa1b SHA512 240b78619783a30919dc62c6240b07d51c8a4e4ee0fcb6c4daba19c6d5830d8623923de6cb984e7310bf5e745b0d20a2471578a2f8650089aca96e9575d3542a
+DIST boto3-1.24.41.gh.tar.gz 523844 BLAKE2B 0cff30d6aba5e8eddb8f545737e22a146ef9a3c33df2ad5b4f6d0ef8fd67cb46183eb7fa21e8a961d2597df8d965478bcb0038f5dda117611bcfe15f0de26eac SHA512 ad3a6035352c54f7ba0197357a5a4e001c8fe7548121a9a3931acb69f9c098feb8da1d1699ac98d3ff00626f39082753434f1c992351a82cf269ce2c6a4eab06
diff --git a/dev-python/boto3/boto3-1.24.41.ebuild b/dev-python/boto3/boto3-1.24.41.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.41.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}