summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-21 04:25:22 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-21 04:25:22 +0100
commit6fd914967aeec7818b173dba23fadfa46d25c25a (patch)
treecf914767f994234566f496d67bbee68f38fb99e8
parentdev-python/boto3: Bump to 1.34.5 (diff)
downloadgentoo-6fd91496.tar.gz
gentoo-6fd91496.tar.bz2
gentoo-6fd91496.zip
app-admin/awscli: Bump to 1.32.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.32.5.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 67eab94c686b..ddf11bc33262 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.32.1.gh.tar.gz 2607388 BLAKE2B 4923e4b610542376639b3290651da23d58
DIST aws-cli-1.32.2.gh.tar.gz 2609043 BLAKE2B 18cf285e54c25605502167e4fa002f522063dd85fc0c09eb44b4513ada49dbe476ca4485bb1cb63e726c5e1bee6934ccfa340ac9c9daecae082abb1abd852426 SHA512 951814c6e5a5dcf74de12e66430c53ca010bae6a8c9984dc11ab456f1cbd4a3f32e5055b3f7587fdf8cff4c224f86bc95858a2556ed5b90981894f706ab1b023
DIST aws-cli-1.32.3.gh.tar.gz 2609467 BLAKE2B 16d5d477c35132c880b5bddefacbca0e844ef702af8a1faf53941a517b5853783dfb202dc7a9936e4475f481ae10b73110f5d617a32f9b859352bedb8a83ddf4 SHA512 2361239e630407ff4304963d7f7481df033073fca1817b6ab9bc0f41b6e024b0ef19d42e2cb1d97b6ad0643f37ccd2c65d5ad9259192dab8e6d795e74dd02748
DIST aws-cli-1.32.4.gh.tar.gz 2610216 BLAKE2B 7767006083a08ed1de114e177d45e37f8858afe7652a4160234514db8a02a3a0c8bf5f37277ea98ca04134d275aeb2e1017e758d678a2603bc3b9c8984bf192d SHA512 715a41701fa6f950e85bb4348b44de000c8147a77cb5d039499992a1dee9c8d447fe24c92886e22cb057c7e1a02113bbdef00dccf8743652b23330e11d662ae3
+DIST aws-cli-1.32.5.gh.tar.gz 2610655 BLAKE2B e85b56e61e0e328c26d2c2fdc33255277f618d9bb4889a118e0a9996f4de282136d998a78dedccf6f4f8430d954e51224d528191265b97f00fa6ad07bbb326d4 SHA512 c58ebb963fa3467e1b7e196748027c37c010a4c559381d32102cdb89b8ef0978298d7722bb98d36109c682f6ee5bb6bb9c66b7603e7f0810ce745ccca5cf0aaf
diff --git a/app-admin/awscli/awscli-1.32.5.ebuild b/app-admin/awscli/awscli-1.32.5.ebuild
new file mode 100644
index 000000000000..28d42f8f7e7b
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.5.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.9.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}