summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-10 10:20:46 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-10 10:43:24 +0300
commit6fe0d05efabf00db94e6e757968b848f1a40d1e4 (patch)
treeadd76cd20b1534238d79bf93a17d57f34ec9a21e
parentdev-python/bcrypt: add 4.0.1 (diff)
downloadgentoo-6fe0d05efabf00db94e6e757968b848f1a40d1e4.tar.gz
gentoo-6fe0d05efabf00db94e6e757968b848f1a40d1e4.tar.bz2
gentoo-6fe0d05efabf00db94e6e757968b848f1a40d1e4.zip
dev-python/sphinxcontrib-spelling: add 7.6.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.6.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index 3f358a827475..7b0f4eca9b37 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-spelling-7.6.0.tar.gz 56329 BLAKE2B e26a3fcb39edf622b20bce0d79d1ce2d2a13e4dd8bdef0bb5cc31108a8ee42afd728975fd65e840c91bc6c6510a57904ebc478b458a52a96031bf44f1cbfa8b6 SHA512 102202eb73767ffface2aa5555c8ee2658bcd3c1eb7f3a925e8713e2f233d1bcf0eb307fed6c264c4e4e6503c30d83a3025b0c39ef608451d2fe86664aeb48c5
+DIST sphinxcontrib-spelling-7.6.1.tar.gz 56828 BLAKE2B 4b059262af6048a037378a48b8f0232d1846365e83069830a877a79296a8004070418199574ee34c3c7cdc644273b0316cbfe45978ff979b91764fd523a408e4 SHA512 504719cf565d27f61e0b30c76129afba7513cb0b974deb9adc40762ea51f62c414844d61d69ab4cc19c95c01d8684097803ba0a8f74c79b3be983ce085ae1e06
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.6.1.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.6.1.ebuild
new file mode 100644
index 000000000000..834977197c58
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.6.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/spelling/
+ https://pypi.org/project/sphinxcontrib-spelling/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ app-dicts/myspell-en
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires the git repo
+ tests/test_filter.py::test_contributors
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ distutils_write_namespace sphinxcontrib
+ rm -rf sphinxcontrib || die
+ epytest tests
+}