summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-21 16:19:32 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-21 16:24:08 +0200
commit6fed4d7e6a69abd8319e1d5a4090cc3f02a680f7 (patch)
treed1af571d346b0fe240288ca85ee116f32d387647
parentsys-devel/gcc: stable 7.4.0-r2 for ia64, bug #694998 (diff)
downloadgentoo-6fed4d7e.tar.gz
gentoo-6fed4d7e.tar.bz2
gentoo-6fed4d7e.zip
dev-libs/libical: Fix USE vala
Reported-by: Marek Bartosiewicz <marek.bartosiewicz@gmail.com> Thanks-to: Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com> Closes: https://bugs.gentoo.org/694922 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/libical/libical-3.0.6.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-libs/libical/libical-3.0.6.ebuild b/dev-libs/libical/libical-3.0.6.ebuild
index 04ea480f906a..91bc8ab78258 100644
--- a/dev-libs/libical/libical-3.0.6.ebuild
+++ b/dev-libs/libical/libical-3.0.6.ebuild
@@ -4,6 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{5,6,7} )
+VALA_USE_DEPEND="vapigen"
inherit cmake-utils python-any-r1 vala
DESCRIPTION="An implementation of basic iCAL protocols"
@@ -21,6 +22,7 @@ BDEPEND="
virtual/pkgconfig
doc? ( app-doc/doxygen )
test? ( ${PYTHON_DEPS} )
+ vala? ( $(vala_depend) )
"
DEPEND="
dev-libs/icu:=
@@ -30,7 +32,6 @@ DEPEND="
dev-libs/gobject-introspection:=
dev-libs/libxml2:2
)
- vala? ( $(vala_depend) )
"
RDEPEND="${DEPEND}
sys-libs/timezone-data
@@ -66,6 +67,12 @@ src_configure() {
-DLIBICAL_BUILD_TESTING=$(usex test)
-DICAL_GLIB_VAPI=$(usex vala)
)
+ if use vala; then
+ mycmakeargs+=(
+ -DVALAC="${VALAC}"
+ -DVAPIGEN="${VAPIGEN}"
+ )
+ fi
cmake-utils_src_configure
}