summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-02-27 19:03:59 +0100
committerUlrich Müller <ulm@gentoo.org>2023-02-27 19:04:45 +0100
commit7010d82e8eb0137dc5176d4a7e5da9e51dae433f (patch)
tree28172c4bab28803ecc0370dea0bff0375f268a7e
parentapp-text/pytextile: add 4.0.2 (diff)
downloadgentoo-7010d82e.tar.gz
gentoo-7010d82e.tar.bz2
gentoo-7010d82e.zip
app-emacs/nxml-gentoo-schemas: add 20230227
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-emacs/nxml-gentoo-schemas/Manifest1
-rw-r--r--app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20230227.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/nxml-gentoo-schemas/Manifest b/app-emacs/nxml-gentoo-schemas/Manifest
index 040c93ee4143..0e02b3138ae8 100644
--- a/app-emacs/nxml-gentoo-schemas/Manifest
+++ b/app-emacs/nxml-gentoo-schemas/Manifest
@@ -1,2 +1,3 @@
DIST nxml-gentoo-schemas-20220730.tar.xz 8856 BLAKE2B 7c08bd09242a30998d6dd535b5143bb920aebaaf209f9acbac734fec258d08711945d58322912f455ef251d59df7f6bad8bec8a758065d67c63cd9dc926950f6 SHA512 91c2183acb3d435e5deca67cb0e9c14fb0af1795a490c8f35076442dcf7f49bff419e3f74d3a34f5790faafd68c643e152ff292c0e994e6ec8f34e4f74efa3fd
DIST nxml-gentoo-schemas-20220916.tar.xz 8884 BLAKE2B c10a5d19268ebf28df6d3dd025d83a8c4e6d6c6bafd553ed1a82d1eb3ffc1afc1ce6bc148c0cd93e11d694e59f48a4bcd53990f842533573f7b37b29ff487f79 SHA512 f2e811945d66828e84411fe84d66399ab6b383456d6d8fd611454fe1c91203c4c29766178e2d52158ab5908a2e197109fb322f7cc5324c1fcb40dfa68757cac6
+DIST nxml-gentoo-schemas-20230227.tar.xz 8812 BLAKE2B 517857a3cd3306daf2570019376eee315abab2f2734283dbfeaf72148471d08e8d2cfbe92b5ad19d3b67104c26da5d02aa2a01ca23b97230aa93d3ab45ec7ec6 SHA512 a92bba645e6122968cdcc0eada9a1a3e5d80f1cb560e95fddcd1cfe60b46699fdf16bad85b86e2d4111d5a10be5124f0d6f8a104038cfa13fd4fff2494f8235b
diff --git a/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20230227.ebuild b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20230227.ebuild
new file mode 100644
index 000000000000..94311b25501f
--- /dev/null
+++ b/app-emacs/nxml-gentoo-schemas/nxml-gentoo-schemas-20230227.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Extension for nxml-mode with Gentoo-specific schemas"
+HOMEPAGE="https://gitweb.gentoo.org/proj/nxml-gentoo-schemas.git/"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="MIT GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+SITEFILE="60${PN}-gentoo.el"
+
+src_compile() { :; }
+
+src_install() {
+ insinto "${SITEETC}/${PN}"
+ doins schemas.xml *.rnc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}