summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2021-10-30 16:10:03 +0300
committerSam James <sam@gentoo.org>2021-11-02 11:00:08 +0000
commit701ccd19940c2feb049c9364fcce163368b69cc8 (patch)
treefede6acbfe20d639c59d5df0b97f3a7e6785bffa
parentdev-libs/libmowgli: Drop 2.1.3-r2 (diff)
downloadgentoo-701ccd19940c2feb049c9364fcce163368b69cc8.tar.gz
gentoo-701ccd19940c2feb049c9364fcce163368b69cc8.tar.bz2
gentoo-701ccd19940c2feb049c9364fcce163368b69cc8.zip
dev-util/codeblocks: Fix x32 contrib plugins. Add boost-libdir option
Closes: https://bugs.gentoo.org/820527 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/22763 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/codeblocks/codeblocks-20.03-r4.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/dev-util/codeblocks/codeblocks-20.03-r4.ebuild b/dev-util/codeblocks/codeblocks-20.03-r4.ebuild
new file mode 100644
index 000000000000..2a412fb830c1
--- /dev/null
+++ b/dev-util/codeblocks/codeblocks-20.03-r4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools wxwidgets xdg
+
+DESCRIPTION="The open source, cross platform, free C, C++ and Fortran IDE"
+HOMEPAGE="https://codeblocks.org/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz
+https://dev.gentoo.org/~leio/distfiles/${P}-fortran.tar.xz
+https://dev.gentoo.org/~leio/distfiles/${P}-fortran-update-v1.7.tar.xz
+https://dev.gentoo.org/~leio/distfiles/${P}-fortran-update-v1.8.tar.xz
+https://dev.gentoo.org/~leio/distfiles/${P}-codecompletion-symbolbrowser-update.tar.xz
+"
+
+# USE="fortran" enables FortranProject plugin (updated to v1.8 2021-05-29 [r230])
+# that is delivered with Code::Blocks 20.03 source code.
+# https://sourceforge.net/projects/fortranproject
+# https://cbfortran.sourceforge.io
+
+IUSE="contrib debug fortran pch"
+
+BDEPEND="virtual/pkgconfig"
+
+RDEPEND="app-arch/zip
+ >=dev-libs/tinyxml-2.6.2-r3
+ >=dev-util/astyle-3.1-r2:0/3.1
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ contrib? (
+ app-admin/gamin
+ app-text/hunspell
+ dev-libs/boost:=
+ )"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-env.patch
+ "${WORKDIR}"/patches/
+ )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ setup-wxwidgets
+
+ # USE="contrib -fortran" setup:
+ use fortran || CONF_WITH_LST=$(use_with contrib contrib-plugins all,-FortranProject)
+ # USE="contrib fortran" setup:
+ use fortran && CONF_WITH_LST=$(use_with contrib contrib-plugins all)
+ # USE="-contrib fortran" setup:
+ use contrib || CONF_WITH_LST=$(use_with fortran contrib-plugins FortranProject)
+
+ econf \
+ --disable-static \
+ $(use_with contrib boost-libdir "${ESYSROOT}/usr/$(get_libdir)") \
+ $(use_enable debug) \
+ $(use_enable pch) \
+ ${CONF_WITH_LST}
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}