summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-19 12:46:11 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-19 13:45:34 +0100
commit70214372b90cb3e40161aea5372f1e318b7bf51f (patch)
tree142f1b19bb13504f4f34774cfa9c4beda13a5868
parentdev-python/pyaudio: Bump (diff)
downloadgentoo-70214372b90cb3e40161aea5372f1e318b7bf51f.tar.gz
gentoo-70214372b90cb3e40161aea5372f1e318b7bf51f.tar.bz2
gentoo-70214372b90cb3e40161aea5372f1e318b7bf51f.zip
dev-python/pycountry: Bump
Package-Manager: portage-2.2.27
-rw-r--r--dev-python/pycountry/Manifest1
-rw-r--r--dev-python/pycountry/pycountry-1.20.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pycountry/Manifest b/dev-python/pycountry/Manifest
index 29c429977b50..7971966428b3 100644
--- a/dev-python/pycountry/Manifest
+++ b/dev-python/pycountry/Manifest
@@ -1,2 +1,3 @@
DIST pycountry-1.18.tar.gz 5020542 SHA256 23bb173d0281e98eb7b432d8dc6819e5fe6573e505454d228558f61e1f5ae1e6 SHA512 eab2bf1711f514b3842aee6004a904573e974b13757cf3c1a388eb8a292d92e3bdb801265a1c146df5fd510bd830297ddfcc64e41c0ed17c385335837f6721dc WHIRLPOOL c697250bbe13e9b471e0b19857d4afcfdaaf85410a07131727e75c23ac5d7f214682e993f1d799c26417e79ae78b83400e0e3401d2bcbb4afae5d40bf9456346
DIST pycountry-1.19.tar.gz 5022557 SHA256 132ecf3343e4bde8fd0c48a4345a4a8a6144fbdcdaf190a43a7e34c99e91be4d SHA512 850d32504c984d1e2959a909fc367da402b1d1adf4f19914fbbf61784fe30487c5ea92e5579ecfd80bff040cffabc9335d55589df32f54af0de032e042a49c77 WHIRLPOOL c21da359d57573e983db9e9d6c5a556e15c4db1436624b6645af24946338d1728beac8ab7c1cc4e66e8a3571f60c1d5e7b398151a322670c1ad7caa21d6ab19f
+DIST pycountry-1.20.tar.gz 5024012 SHA256 0588efa3171e1d5e4cc96fce569ac865964285fdc8dbdc0860844f74598d1f98 SHA512 316e37b4cd800d87f010282a79e47b833b4ee836342ae0e672a5d115c543a8a0e3f508cc4498367aa254317e9747483c7026dac7273d3daa19acd2153635f854 WHIRLPOOL 2516662d06148c5fd3a10efb9715113cf13abe7183fe4b94491b473a24dc47b4d626a77489365b4f2e02a0cc7417ef59dfea21b2b142876981075fc5b05e7d62
diff --git a/dev-python/pycountry/pycountry-1.20.ebuild b/dev-python/pycountry/pycountry-1.20.ebuild
new file mode 100644
index 000000000000..d19095979b11
--- /dev/null
+++ b/dev-python/pycountry/pycountry-1.20.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Database of countries, subdivisions, languages, currencies and script"
+HOMEPAGE="https://bitbucket.org/flyingcircus/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~ppc ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # https://bitbucket.org/techtonik/pycountry/issue/8/test_locales-pycountry-015-pypy
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ if [[ "${EPYTHON}" == pypy || "${EPYTHON}" == pypy3 ]]; then
+ sed -e 's:test_locales:_&:' -i pycountry/tests/test_general.py || die
+ fi
+ py.test ${PN}/tests/test_general.py || die
+ popd > /dev/null
+}