summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-02-04 15:07:51 +0530
committerZac Medico <zmedico@gentoo.org>2024-02-07 19:17:18 -0800
commit702e1b3cf79e9c878a7647c0f6ceb3d5d2237ac7 (patch)
treeeeaad5c773cc7973ca558ea78a4cd8fc7a7813c4
parentapp-containers/podman: add 4.9.2 (diff)
downloadgentoo-702e1b3c.tar.gz
gentoo-702e1b3c.tar.bz2
gentoo-702e1b3c.zip
app-metrics/prometheus-podman-exporter: add 1.8.0
* Go mod bumps to podman-4.9.2 which has few several security fixes * Add systemd USE flag * Remove redundant runtime dependency on podman as it is statically built-in Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Closes: https://github.com/gentoo/gentoo/pull/35159 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--app-metrics/prometheus-podman-exporter/Manifest1
-rw-r--r--app-metrics/prometheus-podman-exporter/prometheus-podman-exporter-1.8.0.ebuild42
-rw-r--r--app-metrics/prometheus-podman-exporter/prometheus-podman-exporter-9999.ebuild11
3 files changed, 47 insertions, 7 deletions
diff --git a/app-metrics/prometheus-podman-exporter/Manifest b/app-metrics/prometheus-podman-exporter/Manifest
index 96e0db495301..185f8366ae5c 100644
--- a/app-metrics/prometheus-podman-exporter/Manifest
+++ b/app-metrics/prometheus-podman-exporter/Manifest
@@ -2,3 +2,4 @@ DIST prometheus-podman-exporter-1.4.0.tar.gz 11934764 BLAKE2B 9f0c7431a15ca0abbf
DIST prometheus-podman-exporter-1.5.0.tar.gz 12032097 BLAKE2B 15e209330342432a1f71e4686a705b6c6dc41d14b9022828cf10cb0538dcbf6b26c47f243ad96aef17eb71470d5af15bd090afc57960ee6d7b8828b2cff32c46 SHA512 d5eca9d0c87cbddfef6a58cdfc5213c65846219ff8a60e9efa038a8e4ca37f36bb6dc0687a78defb80a4901eeb617e8aa689b94ef0a48625548e74816fafbfec
DIST prometheus-podman-exporter-1.6.0.tar.gz 12234381 BLAKE2B 18960a73962ac30c477cabdcc784268088ba2bdf6a0efa6a777f164333b3964b2a881cec8a7f48d6aa5969306f92ed33d2722bfe740e6401dd704dbeb0963e5f SHA512 ef0b565bab8d695f05cadd3689f40161d5a0943a9d54e42611db0ea43dc98aca42d9ce8b33d080c60ab5456df8dc50f4283001562c4edec2e64fe037dd7d6bf1
DIST prometheus-podman-exporter-1.7.0.tar.gz 12251956 BLAKE2B 91a6a217db3fd2b408344f738a7acad5c161adad6da53ef3d3750b73d9135022b0a4c18d85d0f79fc331344462e600574c8cd94477b57261adb29e5ffccdcc83 SHA512 3f9184681f1466ca4bbd32830c8fd233bb7e95af4df0b97cff606e39987d6c608b8847924d3b1c5fe98d058b32324dea86a142065bae7afdb0f99e4cfe0d9b52
+DIST prometheus-podman-exporter-1.8.0.tar.gz 12253412 BLAKE2B 673986f2acce525ab6c9d0858ca6c193bc292bc5e6c8ad50f81921a8f66673c29f724ad562efefb6fe63d556e491432b593b7581af3a01faf44279013a2ec209 SHA512 eb647d8d5c7d30a6676fe192ac2f8c3be5ee67525206c67ac9d0dc06f2fd5fb7dbad838f53fa75f550f5dcfa5c188bd2eb0e7c46b13fe2795b38187ac2fdb81a
diff --git a/app-metrics/prometheus-podman-exporter/prometheus-podman-exporter-1.8.0.ebuild b/app-metrics/prometheus-podman-exporter/prometheus-podman-exporter-1.8.0.ebuild
new file mode 100644
index 000000000000..1547a7a4946d
--- /dev/null
+++ b/app-metrics/prometheus-podman-exporter/prometheus-podman-exporter-1.8.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="Exporter for podman giving containers, pods, images, volumes & networks metrics"
+HOMEPAGE="https://github.com/containers/prometheus-podman-exporter"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/prometheus-podman-exporter.git"
+else
+ SRC_URI="https://github.com/containers/prometheus-podman-exporter/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# Main package
+LICENSE="Apache-2.0"
+# Dependencies
+LICENSE+=" BSD-2 BSD ISC MIT MPL-2.0"
+
+SLOT="0"
+IUSE="btrfs systemd"
+
+# there are no test files so prevent tests
+RESTRICT="test"
+
+src_compile() {
+ export BUILDTAGS="exclude_graphdriver_devicemapper"
+ use !btrfs && BUILDTAGS+=",exclude_graphdriver_btrfs,btrfs_noversion"
+ use systemd && BUILDTAGS+=",systemd"
+ default
+}
+
+src_install() {
+ emake DESTDIR="${ED}/usr/bin" install
+ systemd_dounit "contrib/systemd/prometheus-podman-exporter.service"
+ systemd_douserunit "contrib/systemd/prometheus-podman-exporter.service"
+ einstalldocs
+}
diff --git a/app-metrics/prometheus-podman-exporter/prometheus-podman-exporter-9999.ebuild b/app-metrics/prometheus-podman-exporter/prometheus-podman-exporter-9999.ebuild
index 5d9cfead06de..1547a7a4946d 100644
--- a/app-metrics/prometheus-podman-exporter/prometheus-podman-exporter-9999.ebuild
+++ b/app-metrics/prometheus-podman-exporter/prometheus-podman-exporter-9999.ebuild
@@ -22,18 +22,15 @@ LICENSE="Apache-2.0"
LICENSE+=" BSD-2 BSD ISC MIT MPL-2.0"
SLOT="0"
-IUSE="btrfs"
+IUSE="btrfs systemd"
# there are no test files so prevent tests
RESTRICT="test"
-RDEPEND="
- app-containers/podman[btrfs?]
-"
-DEPEND="${RDEPEND}"
src_compile() {
- export BUILDFLAGS=" -tags exclude_graphdriver_devicemapper"
- use !btrfs && BUILDFLAGS+=",exclude_graphdriver_btrfs,btrfs_noversion"
+ export BUILDTAGS="exclude_graphdriver_devicemapper"
+ use !btrfs && BUILDTAGS+=",exclude_graphdriver_btrfs,btrfs_noversion"
+ use systemd && BUILDTAGS+=",systemd"
default
}