summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-01-09 15:09:17 +0100
committerFabian Groffen <grobian@gentoo.org>2019-01-09 15:09:32 +0100
commit7039cef85032e6e9f65585a879aa6196f50d3b1b (patch)
treed27ddbb942b4f52675bdb0f58e27189f060cd421
parentapp-misc/geoclue: ppc64 stable wrt bug #670864 (diff)
downloadgentoo-7039cef85032e6e9f65585a879aa6196f50d3b1b.tar.gz
gentoo-7039cef85032e6e9f65585a879aa6196f50d3b1b.tar.bz2
gentoo-7039cef85032e6e9f65585a879aa6196f50d3b1b.zip
sys-devel/gdb-apple: force compilation with gcc-apple when not clang
Signed-off-by: Fabian Groffen <grobian@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--sys-devel/gdb-apple/gdb-apple-1752.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/sys-devel/gdb-apple/gdb-apple-1752.ebuild b/sys-devel/gdb-apple/gdb-apple-1752.ebuild
index f374628fb7d5..26baa8079e9b 100644
--- a/sys-devel/gdb-apple/gdb-apple-1752.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-1752.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
APPLE_PV=${PV}
DESCRIPTION="Apple branch of the GNU Debugger, Developer Tools 4.3"
@@ -20,7 +20,8 @@ IUSE="nls"
RDEPEND=">=sys-libs/ncurses-5.2-r2
=dev-db/sqlite-3*"
DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
+ nls? ( sys-devel/gettext )
+ || ( >=sys-devel/gcc-apple-4.2.1 sys-devel/llvm:* )"
S=${WORKDIR}/gdb-${APPLE_PV}/src
@@ -37,6 +38,12 @@ src_prepare() {
}
src_configure() {
+ if tc-is-gcc ; then
+ # force gcc-apple, FSF gcc doesn't grok this code
+ export CC=${CTARGET}-gcc-4.2.1
+ export CXX=${CTARGET}-g++-4.2.1
+ fi
+
replace-flags -O? -O2
econf \
--disable-werror \