summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-26 08:56:08 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-26 13:12:22 +0200
commit703cdd66c58b089d6918e6de131c820b1743c3fc (patch)
tree0362b4a21e23546560d589610833e6b71b9a243c
parentdev-util/libabigail: adjust configure args (diff)
downloadgentoo-703cdd66c58b089d6918e6de131c820b1743c3fc.tar.gz
gentoo-703cdd66c58b089d6918e6de131c820b1743c3fc.tar.bz2
gentoo-703cdd66c58b089d6918e6de131c820b1743c3fc.zip
dev-python/flask-paginate: Bump to 2021.10.26
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/flask-paginate/Manifest1
-rw-r--r--dev-python/flask-paginate/flask-paginate-2021.10.26.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/flask-paginate/Manifest b/dev-python/flask-paginate/Manifest
index 04a470937e9d..594cf7bf8d49 100644
--- a/dev-python/flask-paginate/Manifest
+++ b/dev-python/flask-paginate/Manifest
@@ -1 +1,2 @@
DIST flask-paginate-0.8.1.tar.gz 119751 BLAKE2B 954d39e13619784b1a79abc9f26fc2b3827309f9a3b77cacdd40c8f8d9dfec4c2967894e2d571e26841245da6d264dad71a412e425c87aa0c07b3520274de7c4 SHA512 ca226c79bd944a19760048c1289b554ee048f4f8d1f231f5545423843b7c0616d52ee8024cc68628e11c5f528972897d7fdb1630f87063bbd0e40c4dacf91224
+DIST flask-paginate-2021.10.26.tar.gz 120721 BLAKE2B dd37fa131baf20540620c350bca4a17f791df57c82fabd99e644891707259d330d4225fc666d3e5c31410bc17e10531bf735ab8a01e7129641fa81a9d8fbfe82 SHA512 86a782797a9401eecbbfc25c90834ed93d7c376c3eb6bc05f19edf7ad6f174aca01de9dc3b183c0c268e2995d81984fa1568e08aae8964e429c60f01b7b23736
diff --git a/dev-python/flask-paginate/flask-paginate-2021.10.26.ebuild b/dev-python/flask-paginate/flask-paginate-2021.10.26.ebuild
new file mode 100644
index 000000000000..49d2d8c73c6e
--- /dev/null
+++ b/dev-python/flask-paginate/flask-paginate-2021.10.26.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pagination support for flask"
+HOMEPAGE="https://flask-paginate.readthedocs.io"
+SRC_URI="https://github.com/lixxu/flask-paginate/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests/tests.py
+}