summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2022-03-14 10:42:02 +0100
committerSam James <sam@gentoo.org>2022-03-16 22:33:28 +0000
commit7045573738a58c8edd143fd3b3e6ee00ec6d4378 (patch)
tree1d4ea61ee58fd105da37291f8bc780a48b08b3b3
parentdev-libs/imath: add header for f16c instructions on x86 (diff)
downloadgentoo-7045573738a58c8edd143fd3b3e6ee00ec6d4378.tar.gz
gentoo-7045573738a58c8edd143fd3b3e6ee00ec6d4378.tar.bz2
gentoo-7045573738a58c8edd143fd3b3e6ee00ec6d4378.zip
media-libs/libvmaf: new package
Needed to be able to use Netflix's quality of encoding scoring algorithm with ffmpeg Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--licenses/BSD-2-with-patent42
-rw-r--r--media-libs/libvmaf/Manifest1
-rw-r--r--media-libs/libvmaf/libvmaf-2.3.0.ebuild42
-rw-r--r--media-libs/libvmaf/metadata.xml19
4 files changed, 104 insertions, 0 deletions
diff --git a/licenses/BSD-2-with-patent b/licenses/BSD-2-with-patent
new file mode 100644
index 000000000000..6ecef73b758b
--- /dev/null
+++ b/licenses/BSD-2-with-patent
@@ -0,0 +1,42 @@
+LICENSE - BSD+Patent
+SPDX short identifier: BSD-2-Clause-Patent
+
+Note: This license is designed to provide: a) a simple permissive license; b) that is compatible with the GNU General
+Public License (GPL), version 2; and c) which also has an express patent grant included.
+
+Copyright (c) <year>, <copyright holder>
+
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that the
+following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following
+disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following
+disclaimer in the documentation and/or other materials provided with the distribution.
+
+Subject to the terms and conditions of this license, each copyright holder and contributor hereby grants to those
+receiving rights under this license a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable (except
+for failure to satisfy the conditions of this license) patent license to make, have made, use, offer to sell, sell,
+import, and otherwise transfer this software, where such license applies only to those patent claims, already acquired
+or hereafter acquired, licensable by such copyright holder or contributor that are necessarily infringed by:
+
+(a) their Contribution(s) (the licensed copyrights of copyright holders and non-copyrightable additions of contributors,
+in source or binary form) alone; or
+
+(b) combination of their Contribution(s) with the work of authorship to which such Contribution(s) was added by such
+copyright holder or contributor, if, at the time the Contribution is added, such addition causes such combination to be
+necessarily infringed. The patent license shall not apply to any other combinations which include the Contribution.
+
+Except as expressly stated above, no rights or licenses from any copyright holder or contributor is granted under this
+license, whether expressly, by implication, estoppel or otherwise.
+
+DISCLAIMER
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES,
+INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/media-libs/libvmaf/Manifest b/media-libs/libvmaf/Manifest
new file mode 100644
index 000000000000..1dc0a2fdcdb4
--- /dev/null
+++ b/media-libs/libvmaf/Manifest
@@ -0,0 +1 @@
+DIST libvmaf-2.3.0.tar.gz 18373659 BLAKE2B a08f18cabf99bf421c61c1fa60b946ee62027f06d5ec2a1b78c7d14ef7541a850b83216eed815f586711365ac2e31bdc6b5be811ae4fd6882717bf030d9ffc0f SHA512 10f0af2b1e868d9780a2766c6c06451ea79f4a8cd8f6c546473382587011f9a7c8c5bf80952021980ede62e2188bcb388337c8903a906d50c739be7cdbb8f61b
diff --git a/media-libs/libvmaf/libvmaf-2.3.0.ebuild b/media-libs/libvmaf/libvmaf-2.3.0.ebuild
new file mode 100644
index 000000000000..33cbad2ec7f4
--- /dev/null
+++ b/media-libs/libvmaf/libvmaf-2.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="C libary for Netflix's Perceptual video quality assessment based on multi-method fusion."
+HOMEPAGE="https://github.com/Netflix/vmaf"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Netflix/vmaf.git"
+else
+ SRC_URI="
+ https://github.com/Netflix/vmaf/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2-with-patent"
+SLOT="0"
+
+BDEPEND="
+ dev-lang/nasm
+"
+
+RDEPEND="${BDEPEND}"
+
+S="${WORKDIR}/vmaf-${PV}"
+
+multilib_src_configure() {
+ EMESON_SOURCE="${S}/libvmaf"
+ meson_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ insinto "/usr/share/vmaf"
+ doins -r "${S}/model"
+}
diff --git a/media-libs/libvmaf/metadata.xml b/media-libs/libvmaf/metadata.xml
new file mode 100644
index 000000000000..fe7546eb5ac1
--- /dev/null
+++ b/media-libs/libvmaf/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>adel.ks@zegrapher.com</email>
+ <name>Adel KARA SLIMANE</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ VMAF is a perceptual video quality assessment algorithm developed by Netflix. This software package includes a stand-alone C library libvmaf.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Netflix/vmaf</remote-id>
+ <bugs-to>https://github.com/Netflix/vmaf/issues</bugs-to>
+ </upstream>
+</pkgmetadata>