summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-30 05:30:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-30 06:26:54 +0200
commit707b08caaa910bb42c0c6018d38b0f1250ff36c9 (patch)
treee945d965dc00803ebbd1c9e022aed53d2b74023a
parentdev-python/requests-cache: Bump to 0.9.5 (diff)
downloadgentoo-707b08ca.tar.gz
gentoo-707b08ca.tar.bz2
gentoo-707b08ca.zip
dev-python/hypothesis: Bump to 6.48.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.48.2.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index b459e2f0ac91..a95fc5ed958f 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,5 +1,6 @@
DIST hypothesis-6.48.0.gh.tar.gz 9315489 BLAKE2B e9ddd05c867a83dd8677762178e9e1b9db794a4508d638e90b231d34562e73fc52dd12560b3d43735d06917935337e3a54059d58afe2b8611d4dbf08248b1ff0 SHA512 d6d6155c8a8a4b92772b5e2a398024372201c1228dc23aa8e87d211e3c9f85abbf39bcd3f47c9d165c396e3f4246821f7d51cfe9849cba21c1456f9e02ebe3ca
DIST hypothesis-6.48.1.gh.tar.gz 9316595 BLAKE2B c20d575e9cfaf8d2b26df2861adb1dc1dfbb5a07f9c6cc5281984fc3f83c74b32f0a5ee9cf4fd0ec356f876f0dd1f4723cfb2ee29a7a99062139e45ea2bd5910 SHA512 bb3e5c961466841265aed355f7e0bab2175c8e7c634e2160736aef37a1d917057922023c4fb9cc4e224e453db276091bcf3599693109ecc8a008ce8d6d7344de
+DIST hypothesis-6.48.2.gh.tar.gz 9316125 BLAKE2B a35fde81976dcc874897bb14cbb65f55b4c54f065ed84a69a6ff41274e35013acac404a2234577e9d9f9cc3674d1496102a356289fa3b8d0f1371d7da3d839ad SHA512 3c38941cb17b0a22e547a8da84821b0e83f70da3e4476e8865d91eea90dc0175782084dc2a02b17b8db7a9e177e076a7e4d4044f0cad86f2e658ae01a6be2775
DIST hypothesis-hypothesis-python-6.46.11.gh.tar.gz 9312248 BLAKE2B 78b5ca5bd38bd62d2fe50ab929df075e253c059aed329d6b52051fb01449f8de84ae340ba42a4af94ef592411139a45d34aad232fe4bb2d8412165730bbeca01 SHA512 6fdd54f28d275eb65a4f6e6919437d503eba6254c25e22298c34ac67e6de03cd99a5178b1a475b1da7f7afeed8406e89c20b4818436143f442222d26f0d94796
DIST hypothesis-hypothesis-python-6.47.1.gh.tar.gz 9314265 BLAKE2B c2ad0120ab2cbd565f73d472f0a5a87e4b51ff9cf7c08d75dbc54223ad9fe60ed475577ca7dced64ab02d4cc1ee5d30525677c4acfe720af8251f804e72a3b00 SHA512 1aea9f949242d3a273584cd92e1829654d6ce385efcd631b412374f1f9252d3b759b8e216aaa9a49e26e0c3b12673348eac79d0189881f6a811f11daf14b0873
DIST hypothesis-hypothesis-python-6.47.2.gh.tar.gz 9314053 BLAKE2B df607e7d81a280d916cc3946c71f6b2a6c7004263069e83d2647222730d11276b6c246fedbb07c5a4f3c526df38d6ea5c7999bdb416f0c86b0877d0231418c73 SHA512 b58835fac221353ea9beff227dda81f7776e2b50f6a765e536c83bea129d5c5a862551423d9df5abbc0cf294b358c6c537c62add69b3d5a1f38b22e179d2f83c
diff --git a/dev-python/hypothesis/hypothesis-6.48.2.ebuild b/dev-python/hypothesis/hypothesis-6.48.2.ebuild
new file mode 100644
index 000000000000..b6adc3d4e991
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.48.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" python3_11 pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+
+ epytest tests/cover tests/pytest tests/quality -n "$(makeopts_jobs)"
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}