summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 13:15:06 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 13:17:42 +0100
commit7087b419fac11f0561ea4d42e0c30410dfb8fa42 (patch)
treea54303708929d27bfa3c03b5962d9f8b241f06b2
parentdev-python/nbsphinx: Migrate to PEP517 build (diff)
downloadgentoo-7087b419.tar.gz
gentoo-7087b419.tar.bz2
gentoo-7087b419.zip
dev-python/sphinx-testing: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinx-testing/sphinx-testing-1.0.1-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/sphinx-testing/sphinx-testing-1.0.1-r2.ebuild b/dev-python/sphinx-testing/sphinx-testing-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..ad296d151157
--- /dev/null
+++ b/dev-python/sphinx-testing/sphinx-testing-1.0.1-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing utility classes and functions for Sphinx extensions"
+HOMEPAGE="https://github.com/sphinx-doc/sphinx-testing"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest