summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-04 05:28:14 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-04 05:50:31 +0100
commit7088ab0a8e027f48a85f579e63fd3dd3cb1939ef (patch)
tree32bd7ae17793f77b091fffbe02187877c41aa254
parentdev-python/line_profiler: Bump to 4.0.3 (diff)
downloadgentoo-7088ab0a.tar.gz
gentoo-7088ab0a.tar.bz2
gentoo-7088ab0a.zip
dev-python/tqdm: Bump to 4.65.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.65.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index 9be99bd87782..8fe7adcf405c 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1 +1,2 @@
DIST tqdm-4.64.1.tar.gz 169599 BLAKE2B 4c48f647beb46f22e3c065e2e9c1dc29755c74a2fd29cb8ad8b0dfeab529499d0fbca9296d06453012b3bbf9f9870f95da5e2f37f4c8ba29a71cbee3bd15116b SHA512 bc7ab34145722229737d25d87895c8760b82271c345e1174c83f5896cc893f92a27901d83575472ad124329acdad69bd21e7d68e79aeeefb0e66c83b11989d18
+DIST tqdm-4.65.0.tar.gz 167542 BLAKE2B b1f7b5666600dd5c476ffc9852cdc8905b8819b6b3f812e00495fa38780dda0c59e48956881d46919ce57b13da9dde519fa7e22d91ed58fe43172da8e9043653 SHA512 86315b57d8ceec69ee8970b25372b26b03d2d37f6d06e037e712bf16c7f56eac1c4049291e451c7df62273b91ba7149b400efd0186ceee90268d854e7b476c47
diff --git a/dev-python/tqdm/tqdm-4.65.0.ebuild b/dev-python/tqdm/tqdm-4.65.0.ebuild
new file mode 100644
index 000000000000..168001703194
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.65.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="
+ https://github.com/tqdm/tqdm/
+ https://pypi.org/project/tqdm/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Skip unpredictable performance tests
+ tests/tests_perf.py
+)
+
+python_install_all() {
+ doman tqdm/tqdm.1
+ newbashcomp tqdm/completion.sh tqdm
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}