summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-11-08 13:51:29 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-11-08 13:51:43 +0000
commit7094391e4a0722c5469e86f5ab7becfdcc34617d (patch)
tree687ef3ac80d1a63ed8ea78e9c9f0a2ad83d3760a
parentdev-python/pycurl: Remove old (diff)
downloadgentoo-7094391e4a0722c5469e86f5ab7becfdcc34617d.tar.gz
gentoo-7094391e4a0722c5469e86f5ab7becfdcc34617d.tar.bz2
gentoo-7094391e4a0722c5469e86f5ab7becfdcc34617d.zip
sys-devel/crossdev: bump up to 20101108
Single change: disable USE=libraries for stage1 install Reported-by: Paul Bordukov Closes: https://bugs.gentoo.org/751295 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20201108.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index 2f7da06c4589..f227200edefe 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1 +1,2 @@
DIST crossdev-20200801.tar.xz 28268 BLAKE2B 36f22a2d1422d5f9e27a5559a8c141462853c4dc011ec98c66d235ef262ea9408fd5054b578963fd17ef630ea63e72c068d216f6ffbea7d191d1374a6ecc4033 SHA512 331af1525cdfc66380621b764bfc63178ce962b9071408d1ee08480caad9c0e4782a8fa5e5f3500fd2ea03ccd322895cc95d80106ad9e5b97a0e09ef5d88c94b
+DIST crossdev-20201108.tar.xz 28312 BLAKE2B 2fe86fb7e1b9ed8a3986efcee9bba06a810cf03f00496eee49870e0a9c0a589b8ae461811bf83c76dd22c59e344ddacaeab2ae215aa8f58f3b2e7490399528fc SHA512 28cf1807845c4cc4291c8d576119dbe362ea0f31504ae7a96dbdee636033eab511004b0a8988c4d7425017c3f281b6afa1644db4f9f310a08d69fd7fcd6cdbe0
diff --git a/sys-devel/crossdev/crossdev-20201108.ebuild b/sys-devel/crossdev/crossdev-20201108.ebuild
new file mode 100644
index 000000000000..809478863946
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20201108.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Crossdev"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=sys-apps/portage-2.1
+ >=app-portage/portage-utils-0.55
+ app-shells/bash
+ sys-apps/gentoo-functions
+"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ "${PV}" == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+}