summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-09-09 12:00:49 +0100
committerMarek Szuba <marecki@gentoo.org>2021-09-09 12:20:20 +0100
commit70dc3349825a3f95e899f9e52b18c4c110ddb940 (patch)
tree2fe6a9d1a337f372f71b859c5a41d6b39370ccf0
parentnet-p2p/syncthing: add 1.18.2 (diff)
downloadgentoo-70dc3349.tar.gz
gentoo-70dc3349.tar.bz2
gentoo-70dc3349.zip
sys-auth/yubico-piv-tool: add 2.2.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--sys-auth/yubico-piv-tool/Manifest1
-rw-r--r--sys-auth/yubico-piv-tool/yubico-piv-tool-2.2.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-auth/yubico-piv-tool/Manifest b/sys-auth/yubico-piv-tool/Manifest
index 5a4592f67540..0a4fc772df5e 100644
--- a/sys-auth/yubico-piv-tool/Manifest
+++ b/sys-auth/yubico-piv-tool/Manifest
@@ -1 +1,2 @@
DIST yubico-piv-tool-2.2.0.tar.gz 1309359 BLAKE2B a5be7a48549f864b9322b5bf53726007b593ce7d08cd06f2251aef98cb065d90586e0189e6f3da94d6d274d6998459afa4a55a0d4c1145395f55830f53d334e4 SHA512 b2f8cd73800e0e0778ce36148b962026479f5d3ada3e313acb5a780993c28c41b03e9aa9335ac5b79fed7a418a2d3d3697231adf2da0dd06cd8d22ea5a01aca5
+DIST yubico-piv-tool-2.2.1.tar.gz 1310253 BLAKE2B f5e5d2c351200b2fc57aafdd02a604ee5f15cd8f1a0cb552133a367da2cbf7fe248ec9eba649427b30e8322126be1f9677fd471b38db1f00cda37ccb0ac413c9 SHA512 495a269194d8d9d8957542611959b3fc8e0ae54d1cab5c041f2604590cc740e89e0956b9d595f8a06f138e92b8804def52aae797f199479a81fc1fc3d57bfb96
diff --git a/sys-auth/yubico-piv-tool/yubico-piv-tool-2.2.1.ebuild b/sys-auth/yubico-piv-tool/yubico-piv-tool-2.2.1.ebuild
new file mode 100644
index 000000000000..ba22c83716b4
--- /dev/null
+++ b/sys-auth/yubico-piv-tool/yubico-piv-tool-2.2.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Command-line tool and p11-kit module for the YubiKey PIV application"
+HOMEPAGE="https://developers.yubico.com/yubico-piv-tool/ https://github.com/Yubico/yubico-piv-tool"
+SRC_URI="https://github.com/Yubico/${PN}/archive/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~riscv"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-apps/pcsc-lite
+ <dev-libs/openssl-3.0.0:0=[-bindist(-)]"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+BDEPEND="dev-util/gengetopt
+ sys-apps/help2man
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.1-no-Werror.patch
+ "${FILESDIR}"/${PN}-2.1.1-tests-optional.patch
+ "${FILESDIR}"/${PN}-2.1.1-ykcs11-threads.patch
+)
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_configure() {
+ # As of 2.2.0, man pages end up in /usr/usr/... without the MANDIR override
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIB=OFF
+ -DBUILD_TESTING=$(usex test)
+ -DCMAKE_INSTALL_MANDIR="share/man"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ echo "module: ${EPREFIX}/usr/$(get_libdir)/libykcs11.so" > ${PN}.module \
+ || die "Failed to generate p11-kit module configuration"
+ insinto /usr/share/p11-kit/modules
+ doins ${PN}.module
+}