summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-10 12:49:31 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-10 12:53:47 +0200
commit710d19bf18469c1ccd9e0347edbba8cff9627c12 (patch)
treec531f8ec73ea9019fd5376b80555d634e1d552b5
parentdev-python/hypothesis: Fix stripping CLI script (diff)
downloadgentoo-710d19bf18469c1ccd9e0347edbba8cff9627c12.tar.gz
gentoo-710d19bf18469c1ccd9e0347edbba8cff9627c12.tar.bz2
gentoo-710d19bf18469c1ccd9e0347edbba8cff9627c12.zip
dev-python/setuptools: Reenable tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setuptools/setuptools-57.0.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/setuptools/setuptools-57.0.0.ebuild b/dev-python/setuptools/setuptools-57.0.0.ebuild
index de5047202c8c..dd369730c7d4 100644
--- a/dev-python/setuptools/setuptools-57.0.0.ebuild
+++ b/dev-python/setuptools/setuptools-57.0.0.ebuild
@@ -33,7 +33,7 @@ BDEPEND="
dev-python/pytest-xdist[${PYTHON_USEDEP}]
>=dev-python/virtualenv-20[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
- ' python3_{7..9} pypy3)
+ ' python3_{7..10} pypy3)
)
"
PDEPEND="
@@ -46,10 +46,10 @@ DISTUTILS_IN_SOURCE_BUILD=1
DOCS=( {CHANGES,README}.rst )
python_test() {
- # temporarily skipped, until we port all test deps
- [[ ${EPYTHON} == python3.10 ]] && continue
+ # keep in sync with python_gen_cond_dep above!
+ has "${EPYTHON}" python3.{7..10} pypy3 || continue
- distutils_install_for_testing --via-root
+ distutils_install_for_testing
local deselect=(
# network
'setuptools/tests/test_virtualenv.py::test_pip_upgrade_from_source[None]'