summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-27 10:51:30 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-27 13:10:30 +0100
commit71199f23311718429513278bf24675a43fee7458 (patch)
treeadf7fea1f0c2cd63e119658ce3028bb97bc0f09b
parentsys-devel/llvm: Install LLVMDebuginfod static library for lldb (diff)
downloadgentoo-71199f23311718429513278bf24675a43fee7458.tar.gz
gentoo-71199f23311718429513278bf24675a43fee7458.tar.bz2
gentoo-71199f23311718429513278bf24675a43fee7458.zip
dev-python/dparse: Fix variable ordering
Closes: https://bugs.gentoo.org/923005 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dparse/dparse-0.6.4_beta0.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/dev-python/dparse/dparse-0.6.4_beta0.ebuild b/dev-python/dparse/dparse-0.6.4_beta0.ebuild
index ab41db0efcb2..42cae44b983f 100644
--- a/dev-python/dparse/dparse-0.6.4_beta0.ebuild
+++ b/dev-python/dparse/dparse-0.6.4_beta0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,15 +18,14 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~riscv"
-distutils_enable_tests pytest
-
+# Break circular dependency
+PDEPEND="
+ dev-python/pipenv[${PYTHON_USEDEP}]
+"
BDEPEND="
test? (
- dev-python/pipenv[${PYTHON_USEDEP}]
+ ${PDEPEND}
)
"
-# Break circular dependency
-PDEPEND="
- dev-python/pipenv[${PYTHON_USEDEP}]
-"
+distutils_enable_tests pytest