summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-07 07:08:28 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-07 07:15:59 +0100
commit71338d4b71843ffd2be3fafc7f369c81ee70374e (patch)
tree3ec4ec34ac2b1aa4b25123f740bb4518860d9eb0
parentdev-python/libsass: Bump to 0.23.0 (diff)
downloadgentoo-71338d4b71843ffd2be3fafc7f369c81ee70374e.tar.gz
gentoo-71338d4b71843ffd2be3fafc7f369c81ee70374e.tar.bz2
gentoo-71338d4b71843ffd2be3fafc7f369c81ee70374e.zip
dev-python/wtforms: Bump to 3.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/wtforms/Manifest1
-rw-r--r--dev-python/wtforms/wtforms-3.1.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/wtforms/Manifest b/dev-python/wtforms/Manifest
index c660659408a2..91d4769f9dc8 100644
--- a/dev-python/wtforms/Manifest
+++ b/dev-python/wtforms/Manifest
@@ -1 +1,2 @@
DIST wtforms-3.1.1.tar.gz 134343 BLAKE2B 935e1d0d881573f7fe0cf0099069f49c6f315007755ea27134c8d7db407880f3d5b5e1a427df588aaf427de4e8f09455a09d5c82e666d0fac4055558e3d49e4e SHA512 e7aec26103bf5069cc97474361b4f5788d41181a2560032b8072dc62b29824830b739ddf9df60710685293eec5173d8c44c5fbeee8487f01180a08970abb6c77
+DIST wtforms-3.1.2.tar.gz 134705 BLAKE2B 748ea71ced149220947d0f54d69cc94b3cd8a2e648551556621082418a7555519b275788b961abca1331e6c6d52c1999451cc26b3bc9ab27261ef25de7ffd9fa SHA512 4c4203c735f755cedf9c20ddf9805d1e80096fe2fb499dc91a9608df0ac5eb0ddf6c67eea782f9507d14b14e362454f50b567dc5518ca95ce090305a44436873
diff --git a/dev-python/wtforms/wtforms-3.1.2.ebuild b/dev-python/wtforms/wtforms-3.1.2.ebuild
new file mode 100644
index 000000000000..591754110f11
--- /dev/null
+++ b/dev-python/wtforms/wtforms-3.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYPI_PN="WTForms"
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Flexible forms validation and rendering library for python web development"
+HOMEPAGE="
+ https://wtforms.readthedocs.io/
+ https://github.com/wtforms/wtforms/
+ https://pypi.org/project/WTForms/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/email-validator[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest