summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Hamann <code@ares-macrotechnology.com>2022-11-24 20:31:31 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-12-09 08:53:58 +0200
commit7135783bf86fefb593bfaa4624348c987ea160cf (patch)
treeea0cbb11343dc8046d8d031cf2340da3667b6a91
parentmail-client/mutt-wizard: drop 3.2.1-r1 (diff)
downloadgentoo-7135783bf86fefb593bfaa4624348c987ea160cf.tar.gz
gentoo-7135783bf86fefb593bfaa4624348c987ea160cf.tar.bz2
gentoo-7135783bf86fefb593bfaa4624348c987ea160cf.zip
app-emulation/firecracker-bin: add 1.1.3
Signed-off-by: Sebastian Hamann <code@ares-macrotechnology.com> Closes: https://github.com/gentoo/gentoo/pull/28418 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-emulation/firecracker-bin/Manifest2
-rw-r--r--app-emulation/firecracker-bin/firecracker-bin-1.1.3.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/app-emulation/firecracker-bin/Manifest b/app-emulation/firecracker-bin/Manifest
index 38a92587372e..849c881a38c1 100644
--- a/app-emulation/firecracker-bin/Manifest
+++ b/app-emulation/firecracker-bin/Manifest
@@ -6,3 +6,5 @@ DIST firecracker-v1.1.1-aarch64.tgz 1872407 BLAKE2B 16dd7c0f4fc46beacb3cd72f5c67
DIST firecracker-v1.1.1-x86_64.tgz 1894446 BLAKE2B c2af407efb6a494b3e84a480164f0fa7b8537fe659e36531738a96b013f6bad016a7c44490e65cfcea1fc8c709be64f738134b88793889179c5e8e31ac84489f SHA512 ad5e52f690f18c2c9809b586fa9be35e06ac52b5ba672ad62acb872b7f9e8de91d2dfe200629ad392709e1363ea41169f8d816be482fd46dd6c38c1b9a8e28a9
DIST firecracker-v1.1.2-aarch64.tgz 1873376 BLAKE2B e4498be965aa7706dd6eb3ff50eaf93815dafa1a3e931b449eb209deea0bafcd63bb3ff2b971026880b66d6486001f449ab4fc43ff446d18b8724c38e5663450 SHA512 cb67c35dfc8eddcec0bc707693442fd0f27ce56f73743ac40c0085854a1481ed2d914d0ca0e824eae79363eda87452be15b75ac88c3e93df7fe38b4887ebc3d4
DIST firecracker-v1.1.2-x86_64.tgz 1894723 BLAKE2B 18044fa794826da62f026f61f779427e6ffb606b84e64e3b65bd1904acc06578dfe333130bcd2871371093c2d7d9e5756a744fb7181378bc71a0d80cca586daf SHA512 a2d5c36021c0f309f75182148b794beb3ca6369b63eb1ca9e963e0991df07cc6987d4653a7318b53c76cd82db5827dda059877c4d7f7bbd8d89e313a26c81b30
+DIST firecracker-v1.1.3-aarch64.tgz 2066398 BLAKE2B 0ac0027f6c96e1d8dc72ccb87a1b8d6f438d2c3b459060d02578bbaa12c488081e40d13ef8ed31ffbf1031e7bafd86c47b6b5e513394a401216fd185c6b7b380 SHA512 17233406462ce7e6b528b563656ed35187cbf3172c6979e623cb280036d3d74e2361ca7b14f483a2e5a9635e340a64b83aae444aab504f95f31bd91c500d5823
+DIST firecracker-v1.1.3-x86_64.tgz 2034217 BLAKE2B 7d2f7dc4e4189305db872222d27802f03af8ddc0b5dc1a13e891b662aa50138b5cf5e31935d271a4abcf0052593443634bc9a7e93f5609a03ad16618db9e12ed SHA512 ce0b2723c26cee301de5a47579a578824f583fbf057be6b05737e6474d5591da36816224171d8136de0deb16101ecfd57d4a885cfcf46aa2043ef41e54d79eab
diff --git a/app-emulation/firecracker-bin/firecracker-bin-1.1.3.ebuild b/app-emulation/firecracker-bin/firecracker-bin-1.1.3.ebuild
new file mode 100644
index 000000000000..d91fe042b78a
--- /dev/null
+++ b/app-emulation/firecracker-bin/firecracker-bin-1.1.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info
+
+DESCRIPTION="Secure and fast microVMs for serverless computing (static build)"
+HOMEPAGE="https://firecracker-microvm.github.io https://github.com/firecracker-microvm/firecracker"
+SRC_URI="
+ amd64? (
+ https://github.com/firecracker-microvm/firecracker/releases/download/v${PV}/firecracker-v${PV}-x86_64.tgz
+ )
+ arm64? (
+ https://github.com/firecracker-microvm/firecracker/releases/download/v${PV}/firecracker-v${PV}-aarch64.tgz
+ )"
+
+LICENSE="|| ( Apache-2.0 MIT Apache-2.0-with-LLVM-exceptions ) MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RESTRICT="test strip"
+
+RDEPEND="acct-group/kvm"
+
+QA_PREBUILT="usr/bin/firecracker
+ usr/bin/jailer
+ usr/bin/rebase-snap
+ usr/bin/seccompiler-bin"
+
+S="${WORKDIR}"
+
+pkg_pretend() {
+ if use kernel_linux && kernel_is lt 4 14; then
+ eerror "Firecracker requires a host kernel of 4.14 or higher."
+ elif use kernel_linux; then
+ if ! linux_config_exists; then
+ eerror "Unable to check your kernel for KVM support"
+ else
+ CONFIG_CHECK="~KVM ~TUN ~BRIDGE"
+ ERROR_KVM="You must enable KVM in your kernel to continue"
+ ERROR_KVM_AMD="If you have an AMD CPU, you must enable KVM_AMD in"
+ ERROR_KVM_AMD+=" your kernel configuration."
+ ERROR_KVM_INTEL="If you have an Intel CPU, you must enable"
+ ERROR_KVM_INTEL+=" KVM_INTEL in your kernel configuration."
+ ERROR_TUN="You will need the Universal TUN/TAP driver compiled"
+ ERROR_TUN+=" into your kernel or loaded as a module to use"
+ ERROR_TUN+=" virtual network devices."
+ ERROR_BRIDGE="You will also need support for 802.1d"
+ ERROR_BRIDGE+=" Ethernet Bridging for some network configurations."
+
+ if use amd64 || use amd64-linux; then
+ if grep -q AuthenticAMD /proc/cpuinfo; then
+ CONFIG_CHECK+=" ~KVM_AMD"
+ elif grep -q GenuineIntel /proc/cpuinfo; then
+ CONFIG_CHECK+=" ~KVM_INTEL"
+ fi
+ fi
+
+ # Now do the actual checks setup above
+ check_extra_config
+ fi
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ if use amd64; then
+ my_arch=x86_64
+ elif use arm64; then
+ my_arch=aarch64
+ fi
+
+ dodoc "release-v${PV}-${my_arch}/firecracker_spec-v${PV}.yaml"
+ dodoc "release-v${PV}-${my_arch}/seccomp-filter-v${PV}-${my_arch}.json"
+
+ newbin "release-v${PV}-${my_arch}/firecracker-v${PV}-${my_arch}" firecracker
+ newbin "release-v${PV}-${my_arch}/jailer-v${PV}-${my_arch}" jailer
+ newbin "release-v${PV}-${my_arch}/rebase-snap-v${PV}-${my_arch}" rebase-snap
+ newbin "release-v${PV}-${my_arch}/seccompiler-bin-v${PV}-${my_arch}" seccompiler-bin
+}