summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-13 19:40:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-13 20:44:54 +0200
commit713f68f7a00a237d7384925a565eaacb31d9554c (patch)
treeae97edbf881f8003d52d2cdca930a6d1c6def0b1
parentdev-python/build: Enable testing on py3.13 (diff)
downloadgentoo-713f68f7a00a237d7384925a565eaacb31d9554c.tar.gz
gentoo-713f68f7a00a237d7384925a565eaacb31d9554c.tar.bz2
gentoo-713f68f7a00a237d7384925a565eaacb31d9554c.zip
dev-python/numpy: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/numpy/numpy-2.0.0_rc2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/numpy/numpy-2.0.0_rc2.ebuild b/dev-python/numpy/numpy-2.0.0_rc2.ebuild
index 9b86ed057d7a..0d97ca09f939 100644
--- a/dev-python/numpy/numpy-2.0.0_rc2.ebuild
+++ b/dev-python/numpy/numpy-2.0.0_rc2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=meson-python
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
PYTHON_REQ_USE="threads(+)"
FORTRAN_NEEDED=lapack
@@ -149,6 +149,15 @@ python_test() {
;;
esac
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ _core/tests/test_nditer.py::test_iter_refcount
+ _core/tests/test_limited_api.py::test_limited_api
+ )
+ ;;
+ esac
+
if ! has_version -b "~${CATEGORY}/${P}[${PYTHON_USEDEP}]" ; then
# depends on importing numpy.random from system namespace
EPYTEST_DESELECT+=(