summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-08-20 22:48:51 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-08-20 22:48:51 +0900
commit7149b2d3db746cd24b8e3b984e987598283602ff (patch)
treee1eedfef7c48a314f62009da256904cc658aa2fe
parentapp-i18n/skkfep: fix build with Clang (diff)
downloadgentoo-7149b2d3.tar.gz
gentoo-7149b2d3.tar.bz2
gentoo-7149b2d3.zip
app-i18n/skkfep: update to EAPI 7
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
-rw-r--r--app-i18n/skkfep/metadata.xml8
-rw-r--r--app-i18n/skkfep/skkfep-0.87-r1.ebuild14
2 files changed, 11 insertions, 11 deletions
diff --git a/app-i18n/skkfep/metadata.xml b/app-i18n/skkfep/metadata.xml
index e1a49f498885..6f2ca22da233 100644
--- a/app-i18n/skkfep/metadata.xml
+++ b/app-i18n/skkfep/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>cjk@gentoo.org</email>
- <name>Cjk</name>
- </maintainer>
+ <maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+ </maintainer>
</pkgmetadata>
diff --git a/app-i18n/skkfep/skkfep-0.87-r1.ebuild b/app-i18n/skkfep/skkfep-0.87-r1.ebuild
index 468bfc2ab5e5..7fc8f7512158 100644
--- a/app-i18n/skkfep/skkfep-0.87-r1.ebuild
+++ b/app-i18n/skkfep/skkfep-0.87-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
inherit flag-o-matic toolchain-funcs
@@ -14,12 +14,12 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND="sys-apps/sed
- sys-libs/ncurses:=
+DEPEND="sys-libs/ncurses:="
+RDEPEND="${DEPEND}
+ app-i18n/skk-jisyo"
+BDEPEND="sys-apps/sed
virtual/awk
virtual/pkgconfig"
-RDEPEND="sys-libs/ncurses:=
- app-i18n/skk-jisyo"
PATCHES=(
"${FILESDIR}"/${PN}-gentoo.patch
@@ -47,7 +47,7 @@ src_compile() {
}
src_install() {
- dobin skkfep escmode
- doman skkfep.1
+ dobin ${PN} escmode
+ doman ${PN}.1
einstalldocs
}