summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-12-22 13:34:35 -0700
committerTim Harder <radhermit@gentoo.org>2020-12-22 13:37:44 -0700
commit7158b5d4e5316b12478c84f74ee4d7ff6f938490 (patch)
tree4083efcf80c22240c4d5da9dcd56c25451830054
parentapp-officeext/languagetool: version bump (diff)
downloadgentoo-7158b5d4e5316b12478c84f74ee4d7ff6f938490.tar.gz
gentoo-7158b5d4e5316b12478c84f74ee4d7ff6f938490.tar.bz2
gentoo-7158b5d4e5316b12478c84f74ee4d7ff6f938490.zip
dev-python/pychroot: version bump to 0.10.3
Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--dev-python/pychroot/Manifest1
-rw-r--r--dev-python/pychroot/pychroot-0.10.3.ebuild44
-rw-r--r--dev-python/pychroot/pychroot-9999.ebuild2
3 files changed, 46 insertions, 1 deletions
diff --git a/dev-python/pychroot/Manifest b/dev-python/pychroot/Manifest
index 69cce8bf705f..4147b8898b6a 100644
--- a/dev-python/pychroot/Manifest
+++ b/dev-python/pychroot/Manifest
@@ -1 +1,2 @@
DIST pychroot-0.10.2.tar.gz 23477 BLAKE2B a5145908c565479ba05583e396c669d344193dacaa70b489b152b49cc092cf5f77193324d48917271d01ce67c06ae737815d5c3098d02bc9ed5f1c25c2dca0f9 SHA512 e5ed1b94dc0779890786bb381fba86d13fbcdbc3df411cfcafc868ebb62fe94cf1248d15a20902b4df5dc4420abc0a93fccc7ddcb2f42ad7244a657b5ec99c76
+DIST pychroot-0.10.3.tar.gz 23637 BLAKE2B 9ea0d3fdbabddd2901cf263b9f29eb91a6a6eb732c8973773c69630a320d6e39f458fb4f420f099617ba4f6e43353fe36dc4576cb84bca271a8e7b4db260b36c SHA512 b4d9fab3d2ba9bd5fd9bf6bcb988a1e63ea03aef0c898baf724d51de97943cb41c0223a235f4fa9f733cf737a3089a90006ae5ecb9049d74ec8c78712a1b6e7a
diff --git a/dev-python/pychroot/pychroot-0.10.3.ebuild b/dev-python/pychroot/pychroot-0.10.3.ebuild
new file mode 100644
index 000000000000..9ec7b332eb8a
--- /dev/null
+++ b/dev-python/pychroot/pychroot-0.10.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8,9} )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pychroot.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a python library and cli tool that simplify chroot handling"
+HOMEPAGE="https://github.com/pkgcore/pychroot"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND="~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND=">=dev-python/snakeoil-0.8.9[${PYTHON_USEDEP}]"
+fi
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst README.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pychroot/pychroot-9999.ebuild b/dev-python/pychroot/pychroot-9999.ebuild
index 827ed59fc600..9ec7b332eb8a 100644
--- a/dev-python/pychroot/pychroot-9999.ebuild
+++ b/dev-python/pychroot/pychroot-9999.ebuild
@@ -24,7 +24,7 @@ RESTRICT="!test? ( test )"
if [[ ${PV} == *9999 ]]; then
RDEPEND="~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
else
- RDEPEND="<dev-python/snakeoil-0.8.9[${PYTHON_USEDEP}]"
+ RDEPEND=">=dev-python/snakeoil-0.8.9[${PYTHON_USEDEP}]"
fi
DEPEND="${RDEPEND}"