summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-01-26 15:38:41 +0100
committerJeroen Roovers <jer@gentoo.org>2019-01-26 15:39:20 +0100
commit716c1469ebb6a926578a75fbca0250acd8a7b8f1 (patch)
treef05b68583ce994dd347d4f4560afd993c543cfb7
parentdev-python/pyclipper: amd64 stable (diff)
downloadgentoo-716c1469.tar.gz
gentoo-716c1469.tar.bz2
gentoo-716c1469.zip
net-misc/putty: Rename USE=kerberos to USE=gssapi
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-misc/putty/metadata.xml34
-rw-r--r--net-misc/putty/putty-0.70.ebuild8
-rw-r--r--net-misc/putty/putty-9999.ebuild8
3 files changed, 28 insertions, 22 deletions
diff --git a/net-misc/putty/metadata.xml b/net-misc/putty/metadata.xml
index f8db72350db4..bff885218f39 100644
--- a/net-misc/putty/metadata.xml
+++ b/net-misc/putty/metadata.xml
@@ -1,18 +1,24 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>jer@gentoo.org</email>
- <name>Jeroen Roovers</name>
- </maintainer>
- <longdescription lang="en">
- PuTTY is a free implementation of Telnet and SSH for Windows and Unix
- platforms, along with an xterm terminal emulator. It supports flexible
- terminal setup, mid-session reconfiguration using Ctrl-rightclick,
- multiple X11 authentication protocols, and various other interesting
- things not provided by ssh in an xterm.
- </longdescription>
- <use>
- <flag name="gtk">Build the PuTTY client which requires <pkg>x11-libs/gtk+</pkg>:2. Otherwise only the CLI tools puttygen, plink, pscp and psftp will be built.</flag>
- </use>
+<maintainer type="person">
+<email>jer@gentoo.org</email>
+<name>Jeroen Roovers</name>
+</maintainer>
+<longdescription lang="en">
+PuTTY is a free implementation of Telnet and SSH for Windows and Unix
+platforms, along with an xterm terminal emulator. It supports flexible terminal
+setup, mid-session reconfiguration using Ctrl-rightclick, multiple X11
+authentication protocols, and various other interesting things not provided by
+ssh in an xterm.
+</longdescription>
+<use>
+<flag name="gssapi">
+Enable support for GSSAPI (<pkg>virtual/krb5</pkg>)
+</flag>
+<flag name="gtk">
+Build the PuTTY client which requires <pkg>x11-libs/gtk+</pkg>:3. If disabled
+only the CLI tools puttygen, plink, pscp and psftp will be built.
+</flag>
+</use>
</pkgmetadata>
diff --git a/net-misc/putty/putty-0.70.ebuild b/net-misc/putty/putty-0.70.ebuild
index 1d6f330296b3..888ed3b7bbbb 100644
--- a/net-misc/putty/putty-0.70.ebuild
+++ b/net-misc/putty/putty-0.70.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -10,7 +10,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc +gtk ipv6 kerberos"
+IUSE="doc +gtk ipv6 gssapi"
SRC_URI="
https://dev.gentoo.org/~jer/${PN}-icons.tar.bz2
https://the.earth.li/~sgtatham/${PN}/latest/${P}.tar.gz
@@ -25,7 +25,7 @@ RDEPEND="
x11-libs/libX11
x11-libs/pango
)
- kerberos? ( virtual/krb5 )
+ gssapi? ( virtual/krb5 )
"
DEPEND="
${RDEPEND}
@@ -47,7 +47,7 @@ src_prepare() {
src_configure() {
cd "${S}"/unix || die
econf \
- $(use_with kerberos gssapi) \
+ $(use_with gssapi) \
$(use_with gtk)
}
diff --git a/net-misc/putty/putty-9999.ebuild b/net-misc/putty/putty-9999.ebuild
index c677a8a6686d..9d0477fe17e1 100644
--- a/net-misc/putty/putty-9999.ebuild
+++ b/net-misc/putty/putty-9999.ebuild
@@ -12,7 +12,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE="doc +gtk ipv6 kerberos"
+IUSE="doc +gtk ipv6 gssapi"
RDEPEND="
!net-misc/pssh
@@ -23,7 +23,7 @@ RDEPEND="
x11-libs/libX11
x11-libs/pango
)
- kerberos? ( virtual/krb5 )
+ gssapi? ( virtual/krb5 )
"
DEPEND="
${RDEPEND}
@@ -53,8 +53,8 @@ src_prepare() {
src_configure() {
cd "${S}"/unix || die
econf \
- $(use_with kerberos gssapi) \
- $(use_with gtk)
+ $(use_with gssapi) \
+ $(use_with gtk gtk=3)
}
src_compile() {