summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-06-24 22:27:39 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-06-24 22:27:39 +0100
commit7180d5f150295b7a8f5fd492a637f8a7b10f0253 (patch)
treec3a90656aa08861a8a138efdf46b118c79ad2926
parentdev-python/jsonpickle: Bump to version 1.2 (diff)
downloadgentoo-7180d5f150295b7a8f5fd492a637f8a7b10f0253.tar.gz
gentoo-7180d5f150295b7a8f5fd492a637f8a7b10f0253.tar.bz2
gentoo-7180d5f150295b7a8f5fd492a637f8a7b10f0253.zip
www-apps/phpBB: Version bump to 3.2.7
Bug: https://bugs.gentoo.org/678512 Closes: https://bugs.gentoo.org/615182 Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--www-apps/phpBB/Manifest1
-rwxr-xr-xwww-apps/phpBB/files/permissions19
-rw-r--r--www-apps/phpBB/files/postinstall-en.txt30
-rw-r--r--www-apps/phpBB/metadata.xml11
-rw-r--r--www-apps/phpBB/phpBB-3.2.7.ebuild50
5 files changed, 92 insertions, 19 deletions
diff --git a/www-apps/phpBB/Manifest b/www-apps/phpBB/Manifest
index ef210a44d71c..06073694d4da 100644
--- a/www-apps/phpBB/Manifest
+++ b/www-apps/phpBB/Manifest
@@ -1 +1,2 @@
DIST phpBB-3.1.10.tar.bz2 2150999 BLAKE2B c0dce8b554f9bfd19f0e470fa0b96637f26969339f4ef6f87d04d5e492f0028d24e0adc76c8600b7a7d95c6531aa6971b646a02f22f731195c5a9491ea465bd0 SHA512 077a529075ea4e0691f9125be521b3fa8d4a078f9234b40bc5495faf00e1389808da40176ab8c8d9c66db259ebbf252d7292919d5c8e96e93c0bbda8d19695e2
+DIST phpBB-3.2.7.tar.bz2 4384851 BLAKE2B 68af960efa04a30f81869b205d9c43ace86a4a4411a4cb969cdf5d52c8bf4f87f806fc3b2c71941f15be295afe5faa0d606af72a734356c3a7f0f97fb73d3f01 SHA512 f6cf728c022d803f2b39560037b987e832f4ee4583a377f63e01a1529b58e275db4f13386a0d70b50cfb40621d7573a26e349702f901a549cedda9db7f79d4d2
diff --git a/www-apps/phpBB/files/permissions b/www-apps/phpBB/files/permissions
new file mode 100755
index 000000000000..b5c21c879eb1
--- /dev/null
+++ b/www-apps/phpBB/files/permissions
@@ -0,0 +1,19 @@
+#!/bin/bash -e
+
+if [[ $1 = install ]]; then
+ # Ensure database credentials are not world-readable.
+ chmod -v o= "${MY_INSTALLDIR}"/config.php
+
+ # These paths need to be writeable by the PHP user.
+ PATHS=( "${MY_INSTALLDIR}"/{cache/,config.php,download/,files/,store/,images/avatars/upload/} )
+
+ # Assume the PHP user is in the config group.
+ GID=${VHOST_CONFIG_GID}
+
+ # If that group is root, assume the web server group instead.
+ [[ ${GID} = 0 || ${GID} = root ]] && GID=${VHOST_SERVER_GID}
+
+ # Make the paths writeable by that group.
+ chgrp -v "${GID}" "${PATHS[@]}"
+ chmod -v g+w "${PATHS[@]}"
+fi
diff --git a/www-apps/phpBB/files/postinstall-en.txt b/www-apps/phpBB/files/postinstall-en.txt
index 6787a37ca813..8bdf1386e4de 100644
--- a/www-apps/phpBB/files/postinstall-en.txt
+++ b/www-apps/phpBB/files/postinstall-en.txt
@@ -1,22 +1,14 @@
-You are almost done!
+IMPORTANT! Ensure that the group assigned to group-writeable paths
+such as config.php (see above) is one your PHP user is a member
+of. This may or may not be your web server group, ${VHOST_SERVER_GID}.
+If not, adjust your PHP user and/or reinstall the application with
+webapp-config while specifying an appropriate group with -g. Then...
- 0. Setup a database (e.g. MySQL: see
- http://www.gentoo.org/doc/en/mysql-howto.xml)
+1. Set up a database.
+2. Continue the installation by visiting the URL in your browser.
+3. Delete the "install" folder as follows:
- 1. Login on
+ # cd ${MY_INSTALLDIR}
+ # rm -rf install
- http://${VHOST_HOSTNAME}/${VHOST_APPDIR}
-
- and finish the installation.
-
- 2. Move into the directory where you installed phpBB and remove
- the "install" folder:
-
- # cd ${MY_INSTALLDIR}
- # rm -rf install
-
- 3. You can now launch your browser and point it to your phpBB site:
-
- http://${VHOST_HOSTNAME}/${VHOST_APPDIR}
-
- Enjoy phpBB!
+4. phpBB is now ready to use. Enjoy!
diff --git a/www-apps/phpBB/metadata.xml b/www-apps/phpBB/metadata.xml
index 575e4216b633..14d03d3e9a1f 100644
--- a/www-apps/phpBB/metadata.xml
+++ b/www-apps/phpBB/metadata.xml
@@ -9,4 +9,15 @@
<email>chewi@gentoo.org</email>
<name>James Le Cuirot</name>
</maintainer>
+ <longdescription>
+ phpBB is a free flat-forum bulletin board software solution that can be used
+ to stay in touch with a group of people or can power your entire website.
+ With an extensive database of user-created extensions and styles database
+ containing hundreds of style and image packages to customise your board,
+ you can create a very unique forum in minutes.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://tracker.phpbb.com</bugs-to>
+ <remote-id type="github">phpbb/phpbb</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/www-apps/phpBB/phpBB-3.2.7.ebuild b/www-apps/phpBB/phpBB-3.2.7.ebuild
new file mode 100644
index 000000000000..c44df8c4c35c
--- /dev/null
+++ b/www-apps/phpBB/phpBB-3.2.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="An open-source PHP-based bulletin board package"
+HOMEPAGE="https://www.phpbb.com/"
+SRC_URI="https://www.phpbb.com/files/release/${P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~sparc ~x86"
+IUSE="ftp gd mssql mysqli postgres sqlite zlib"
+REQUIRED_USE="|| ( mssql mysqli postgres sqlite )"
+
+PHPV="5.4:*"
+RDEPEND=">=virtual/httpd-php-${PHPV}
+ >=dev-lang/php-${PHPV}[ftp?,gd?,json,mssql?,mysqli?,postgres?,sqlite?,xml,zlib?]"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${PN}${PV%%.*}"
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php
+ webapp_hook_script "${FILESDIR}"/permissions
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+
+ # phpBB needs docs together with the other files.
+ dosym "${MY_HTDOCSDIR}"/docs /usr/share/doc/${PF}
+}
+
+pkg_postinst() {
+ einfo "phpBB needs a specific web server configuration. For Apache httpd, an"
+ einfo "example configuration is provided via .htaccess files. For lighttpd and"
+ einfo "NGINX, example configuration files can be found in the documentation."
+
+ if use vhosts; then
+ echo
+ ewarn "When installing with webapp-config, specify a group that includes your"
+ ewarn "PHP user with the -g option. It will default to the web server group"
+ ewarn "when running webapp-config as root."
+ fi
+}