summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-16 14:04:03 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-16 14:04:03 +1200
commit718e746de9728f24f346870c6652bbdece559965 (patch)
tree3d93f8c5750a48b3dcfae84af7c1e680bf26bbac
parentdev-perl/Authen-Libwrap: -r bump fix for bug #737212 (diff)
downloadgentoo-718e746d.tar.gz
gentoo-718e746d.tar.bz2
gentoo-718e746d.zip
dev-perl/BerkeleyDB: Fix libdir re bug #737190
Bug: https://bugs.gentoo.org/737190 Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/BerkeleyDB/BerkeleyDB-0.630.0-r2.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-perl/BerkeleyDB/BerkeleyDB-0.630.0-r2.ebuild b/dev-perl/BerkeleyDB/BerkeleyDB-0.630.0-r2.ebuild
new file mode 100644
index 000000000000..8a644c1a2e6f
--- /dev/null
+++ b/dev-perl/BerkeleyDB/BerkeleyDB-0.630.0-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PMQS
+DIST_VERSION=0.63
+inherit perl-module db-use multilib
+
+DESCRIPTION="This module provides Berkeley DB interface for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Install DB_File if you want older support. BerkleyDB no longer
+# supports less than 2.0.
+
+RDEPEND="
+ >=sys-libs/db-2.0:=
+ <sys-libs/db-7:=
+"
+DEPEND="
+ >=sys-libs/db-2.0:=
+ <sys-libs/db-7:=
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker"
+
+PERL_RM_FILES=(
+ "t/meta-json.t"
+ "t/meta-yaml.t"
+ "t/pod.t"
+ "scan.pl"
+ "mkconsts.pl"
+)
+# parallel really broken
+DIST_TEST="do"
+src_prepare() {
+ local DB_SUPPORTED=(
+ 6 5 4 3 2
+ )
+ # on Gentoo/FreeBSD we cannot trust on the symlink /usr/include/db.h
+ # as for Gentoo/Linux, so we need to esplicitely declare the exact berkdb
+ # include path
+ local dbdir="$(db_includedir "${DB_SUPPORTED[@]}" )"
+ local dbname="$(db_libname "${DB_SUPPORTED[@]}" )"
+ einfo "DB Include Dir: ${dbdir}"
+ einfo "DB library: ${dbname}"
+
+ rm -f "${S}/config.in" || die "Can't remove packaged config.in"
+
+ printf "INCLUDE = %s\nLIB = %s\nDBNAME = -l%s\n" \
+ "${dbdir}" \
+ "${EPREFIX}/usr/$(get_libdir)" \
+ "${dbname}" > "${S}"/config.in || die "Can't write config.in"
+
+ perl-module_src_prepare
+}
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}