summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-28 08:27:04 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-28 08:31:06 -0700
commit7199cc15642df1e20e2d7c44435ec44f09bf1f6b (patch)
tree19e9996b5d7250505574b71937433f0d731d592f
parentgnome-extra/zenity: Version bump to 3.42.1 (diff)
downloadgentoo-7199cc15642df1e20e2d7c44435ec44f09bf1f6b.tar.gz
gentoo-7199cc15642df1e20e2d7c44435ec44f09bf1f6b.tar.bz2
gentoo-7199cc15642df1e20e2d7c44435ec44f09bf1f6b.zip
net-libs/libmbim: Version bump to 1.26.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-libs/libmbim/Manifest1
-rw-r--r--net-libs/libmbim/libmbim-1.26.4.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/libmbim/Manifest b/net-libs/libmbim/Manifest
index 0e85558248d8..cfef3e37f43c 100644
--- a/net-libs/libmbim/Manifest
+++ b/net-libs/libmbim/Manifest
@@ -1 +1,2 @@
DIST libmbim-1.26.2.tar.xz 561096 BLAKE2B 11e5339b63dbaca8fb6d31ce2afaf4897774aa4b531cfbb09bb400f64ab975495093b711d0a836feff86e3d9fc72ae2b85ab5cd84fab3d266e0fecf1129125d0 SHA512 7cce1fa6ff5630a1cc565a2198544de9f4a1db20b30304fac96de6c698eaf56b17fe6ccb089151623d4484d88fda6abe980bced19dfbf0d3ef425fc954fb5844
+DIST libmbim-1.26.4.tar.xz 566188 BLAKE2B 96fb932e89455364eec39d879256eb10efd4fafc18c0dc69619b3a73cea1e62e3ea50b828c2785082e6422c39d8775c9bc1c084db3aaafdf054b1e7aa7d6929f SHA512 a530a3611aa353d7b7a4a3d845a8a8b08e508004f44e9bc63a4c04729589397e264a5dca499ebb7c57f135e6848909d78124c4799bd932c24271c57824c3b5d8
diff --git a/net-libs/libmbim/libmbim-1.26.4.ebuild b/net-libs/libmbim/libmbim-1.26.4.ebuild
new file mode 100644
index 000000000000..81724693c402
--- /dev/null
+++ b/net-libs/libmbim/libmbim-1.26.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-any-r1
+
+DESCRIPTION="Mobile Broadband Interface Model (MBIM) modem protocol helper library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libmbim/ https://gitlab.freedesktop.org/mobile-broadband/libmbim"
+SRC_URI="https://www.freedesktop.org/software/libmbim/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-libs/glib-2.56:2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --disable-Werror \
+ --disable-static \
+ --disable-gtk-doc
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}