summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-02 08:49:33 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-02 10:48:52 +0100
commit7199fc4b657a3ed7daef103d0d173493c52c2506 (patch)
tree73d2b7e59f1e1fe39ee8b51abdfa177aed63aa4a
parentdev-python/dill: Bump to 0.3.3 (diff)
downloadgentoo-7199fc4b.tar.gz
gentoo-7199fc4b.tar.bz2
gentoo-7199fc4b.zip
dev-python/kiwisolver: Bump to 1.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/kiwisolver/Manifest1
-rw-r--r--dev-python/kiwisolver/kiwisolver-1.3.1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/kiwisolver/Manifest b/dev-python/kiwisolver/Manifest
index d7004669eba5..98d71550d542 100644
--- a/dev-python/kiwisolver/Manifest
+++ b/dev-python/kiwisolver/Manifest
@@ -1,2 +1,3 @@
DIST kiwisolver-1.2.0.tar.gz 54244 BLAKE2B 42590c2cbb78b3c2ed568373616e772326bf5a0e133396d9e9cf6468132ec88b45d40f68f51baff7bc22ca261567ebab81cf2585009657bd2a59df4e97c33f1f SHA512 05541ff46cc64b9958d714452138dc7bb343e6cc9308408a3f8cf25242e9640af37f8bfd22a7038e8ca70a895f57bdb983346259bce22b1630ac10b974d00a0e
DIST kiwisolver-1.3.0.tar.gz 86440 BLAKE2B 931a230909a7778aac3bc93fb24538c7b9e0a3cf1dea33fcf374fd6576d56b80a50597d14c6431f659326222c8810416897fcc9ce2725ca5341891f65aedc5b2 SHA512 64bb475f86e6f409318c5030cd2874bf060c26bf6c1ea62bfb96c1ae27f7326fcd6fc575cbdad7351808d18ae9b9f6664eb312019d432cd6a4c0b8af4fa317b6
+DIST kiwisolver-1.3.1.tar.gz 86948 BLAKE2B 4e03547842e831424aef5be880021aea8d0fef372900bcb9b55f2367fc89f728250b936702fd737807579be34e4ff7489d5669f5113e95612352a293d9f883ea SHA512 0f5c1e516c334d358b8679313035dd45386381965853005271c73e3f4421fb27e3ca5a43b4f2dc85d693f4151427dae9b34d372fe72fcc1a186abd85a54a225a
diff --git a/dev-python/kiwisolver/kiwisolver-1.3.1.ebuild b/dev-python/kiwisolver/kiwisolver-1.3.1.ebuild
new file mode 100644
index 000000000000..2d2ec37813ab
--- /dev/null
+++ b/dev-python/kiwisolver/kiwisolver-1.3.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="An efficient C++ implementation of the Cassowary constraint solving algorithm"
+HOMEPAGE="https://github.com/nucleic/kiwi"
+SRC_URI="https://github.com/nucleic/kiwi/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/kiwi-${PV}
+
+LICENSE="Clear-BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/cppy-1.1.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest