summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYury Martynov <email@linxon.ru>2019-12-03 21:54:44 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-12-05 08:47:24 +0200
commit71bad4e56e346f4c8cf2a657311dd6c54590017e (patch)
tree8f3d06a8dcff16ae3a4c27ad70ad3c56a904f905
parentmedia-libs/libvpx: bump to v1.8.1 (diff)
downloadgentoo-71bad4e56e346f4c8cf2a657311dd6c54590017e.tar.gz
gentoo-71bad4e56e346f4c8cf2a657311dd6c54590017e.tar.bz2
gentoo-71bad4e56e346f4c8cf2a657311dd6c54590017e.zip
app-emulation/img: EAPI bump, fix bugs and other minor changes
Closes: https://bugs.gentoo.org/699564 Closes: https://bugs.gentoo.org/679282 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Yury Martynov <email@linxon.ru> Closes: https://github.com/gentoo/gentoo/pull/13851 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-emulation/img/img-0.5.7-r1.ebuild34
-rw-r--r--app-emulation/img/img-0.5.7.ebuild31
-rw-r--r--app-emulation/img/metadata.xml9
3 files changed, 42 insertions, 32 deletions
diff --git a/app-emulation/img/img-0.5.7-r1.ebuild b/app-emulation/img/img-0.5.7-r1.ebuild
new file mode 100644
index 000000000000..4b2367c13e4e
--- /dev/null
+++ b/app-emulation/img/img-0.5.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/genuinetools/img"
+
+inherit golang-vcs-snapshot
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="https://github.com/genuinetools/img/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+DEPEND="seccomp? ( sys-libs/libseccomp )"
+RDEPEND="${DEPEND}
+ app-emulation/runc"
+
+src_compile() {
+ GOPATH="${S}:$(get_golibdir_gopath)" \
+ GOCACHE="${T}/go-cache" \
+ IMG_DISABLE_EMBEDDED_RUNC=1 \
+ go build -v -work -x -tags "noembed $(usev seccomp)" \
+ -ldflags="-s -w -X ${EGO_PN}/version.VERSION=${PV}" "${EGO_PN}" || die
+}
+
+src_install() {
+ dobin img
+ dodoc "src/${EGO_PN}"/{README.md,AUTHORS}
+}
diff --git a/app-emulation/img/img-0.5.7.ebuild b/app-emulation/img/img-0.5.7.ebuild
deleted file mode 100644
index 21373b5f486d..000000000000
--- a/app-emulation/img/img-0.5.7.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit golang-build golang-vcs-snapshot
-
-EGO_PN="github.com/genuinetools/img"
-GIT_COMMIT="d14bb92b69804443263d647647b0833013b8df91"
-ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
-HOMEPAGE="https://github.com/genuinetools/img"
-SRC_URI="${ARCHIVE_URI}"
-LICENSE="MIT"
-SLOT="0"
-IUSE="seccomp"
-
-RESTRICT="test"
-
-src_compile() {
- local TAGS=$(usex seccomp 'seccomp' '')
- pushd src/${EGO_PN} || die
- GOPATH="${S}" go build -mod vendor -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
- popd || die
-}
-
-src_install() {
- dobin bin/*
- dodoc -r src/${EGO_PN}/README.md
-}
diff --git a/app-emulation/img/metadata.xml b/app-emulation/img/metadata.xml
index 7213eb804f94..236a80be46df 100644
--- a/app-emulation/img/metadata.xml
+++ b/app-emulation/img/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>email@linxon.ru</email>
+ <name>Yury Martynov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">genuinetools/img</remote-id>
</upstream>