summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-02-15 00:00:04 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-02-15 00:01:04 +0100
commit71c267ba734e02c6d2680299cf67d2b1306a4a9b (patch)
treeebfdd44b2b416e8f806416bce0f8065886f29188
parentdev-lisp/asdf: Restoring old version 1.89 since dev-lisp/asdf-binary-location... (diff)
downloadgentoo-71c267ba734e02c6d2680299cf67d2b1306a4a9b.tar.gz
gentoo-71c267ba734e02c6d2680299cf67d2b1306a4a9b.tar.bz2
gentoo-71c267ba734e02c6d2680299cf67d2b1306a4a9b.zip
app-crypt/certbot: Version bump to 0.11.1
Package-Manager: portage-2.3.3
-rw-r--r--app-crypt/certbot/Manifest1
-rw-r--r--app-crypt/certbot/certbot-0.11.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index c81b914ef6a1..b15a8195cc26 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1 +1,2 @@
DIST certbot-0.10.1.tar.gz 823669 SHA256 c91b5fddb50dfd46545c12c1e96d1bb5e2794652c11421a6f5d9dad2bbca4d52 SHA512 4e45280b9cb6db3f8dcecfbf0cf64c990ea58d8607ed1aea9853c7248f8830301cc8685126eeb0d0c2ef0e23298c9070b291110d733e72867967bc9506900702 WHIRLPOOL ae08a9236adf69915c4a141106aa104563b1298f9fd3a32491ed8c45fddc9f32243154ba5bde9af7a8b74a95a1d2b7d337e4cbcc37f35ba997a7a50eb2f15200
+DIST certbot-0.11.1.tar.gz 817693 SHA256 89c45639746a79a22e32d86dbf9352cda1a4ea218aa1433d3aa61d90c715f52c SHA512 77ab66be8e9e16c3588f9a822db553c3ba8caf5bda91a810c0bccfd2bed144ccab06dae33551df474dba05a679045dc02966bc6f8facecdcba3f00c7b9773f0a WHIRLPOOL 5514e471ef9f7fd75321da7828927c34bec757bcd0c7477814da953286f6a0a414b5cf5969243df41100f172bb2f0b451019f7e1130123a2fac9fcd88a0abd99
diff --git a/app-crypt/certbot/certbot-0.11.1.ebuild b/app-crypt/certbot/certbot-0.11.1.ebuild
new file mode 100644
index 000000000000..c6bca773dc84
--- /dev/null
+++ b/app-crypt/certbot/certbot-0.11.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+CDEPEND=">=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-0.7[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? (
+ >=dev-python/astroid-1.3.5[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pep8[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.4.2[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests -v ${PN} || die
+}