summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-27 21:15:47 +0000
committerSam James <sam@gentoo.org>2023-12-27 21:16:24 +0000
commit71c29bdbd17e75bc52a033709095038ae77e0352 (patch)
tree33fc1092dc5309ab33c244b74ab9bb24ca6d0166
parentRevert "net-misc/dahdi-tools: treeclean" (diff)
downloadgentoo-71c29bdbd17e75bc52a033709095038ae77e0352.tar.gz
gentoo-71c29bdbd17e75bc52a033709095038ae77e0352.tar.bz2
gentoo-71c29bdbd17e75bc52a033709095038ae77e0352.zip
Revert "net-misc/asterisk: remove masked IUSE="dahdi""
This reverts commit d9cf9e165c0025b84d62e571a3d3ad7377859f94. Removal date was not yet met & there are plans to possibly resurrect dahdi, per the bug. Bug: https://bugs.gentoo.org/914477 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/asterisk/asterisk-16.30.0.ebuild10
-rw-r--r--net-misc/asterisk/asterisk-16.30.1.ebuild10
-rw-r--r--net-misc/asterisk/asterisk-18.17.0.ebuild10
-rw-r--r--net-misc/asterisk/asterisk-18.18.0.ebuild10
-rw-r--r--net-misc/asterisk/asterisk-18.18.1.ebuild10
-rw-r--r--net-misc/asterisk/asterisk-20.3.0.ebuild10
-rw-r--r--net-misc/asterisk/asterisk-20.3.1.ebuild10
-rw-r--r--net-misc/asterisk/metadata.xml1
-rw-r--r--profiles/base/package.use.mask5
9 files changed, 48 insertions, 28 deletions
diff --git a/net-misc/asterisk/asterisk-16.30.0.ebuild b/net-misc/asterisk/asterisk-16.30.0.ebuild
index 289cebb6cb7b..a684412a9be4 100644
--- a/net-misc/asterisk/asterisk-16.30.0.ebuild
+++ b/net-misc/asterisk/asterisk-16.30.0.ebuild
@@ -19,7 +19,7 @@ IUSE_VOICEMAIL_STORAGE=(
voicemail_storage_odbc
voicemail_storage_imap
)
-IUSE="${IUSE_VOICEMAIL_STORAGE[*]} alsa blocks bluetooth calendar +caps cluster codec2 curl debug deprecated doc freetds gtalk http iconv ilbc ldap lua mysql newt odbc oss pjproject portaudio postgres radius selinux snmp span speex srtp +ssl static statsd syslog systemd unbound vorbis xmpp"
+IUSE="${IUSE_VOICEMAIL_STORAGE[*]} alsa blocks bluetooth calendar +caps cluster codec2 curl dahdi debug deprecated doc freetds gtalk http iconv ilbc ldap lua mysql newt odbc oss pjproject portaudio postgres radius selinux snmp span speex srtp +ssl static statsd syslog systemd unbound vorbis xmpp"
IUSE_EXPAND="VOICEMAIL_STORAGE"
REQUIRED_USE="gtalk? ( xmpp )
lua? ( ${LUA_REQUIRED_USE} )
@@ -55,6 +55,10 @@ DEPEND="acct-user/asterisk
cluster? ( sys-cluster/corosync )
codec2? ( media-libs/codec2:= )
curl? ( net-misc/curl )
+ dahdi? (
+ net-libs/libpri
+ net-misc/dahdi-tools
+ )
freetds? ( dev-db/freetds )
gtalk? ( dev-libs/iksemel )
http? ( dev-libs/gmime:2.6 )
@@ -227,9 +231,6 @@ src_configure() {
# Disable conversion tools (which fails to compile in some cases).
_menuselect --disable astdb2bdb menuselect.makeopts
- # dahdi isn't packaged anymore
- _menuselect --disable app_dahdiras app_meetme chan_dahdi codec_dahdi res_timing_dahdi
-
# The others are based on USE-flag settings
_use_select alsa chan_alsa
_use_select bluetooth chan_mobile
@@ -237,6 +238,7 @@ src_configure() {
_use_select cluster res_corosync
_use_select codec2 codec_codec2
_use_select curl func_curl res_config_curl res_curl
+ _use_select dahdi app_dahdiras app_meetme chan_dahdi codec_dahdi res_timing_dahdi
_use_select deprecated app_macro
_use_select freetds {cdr,cel}_tds
_use_select gtalk chan_motif
diff --git a/net-misc/asterisk/asterisk-16.30.1.ebuild b/net-misc/asterisk/asterisk-16.30.1.ebuild
index 65a83df9721a..b2a0d086ac1e 100644
--- a/net-misc/asterisk/asterisk-16.30.1.ebuild
+++ b/net-misc/asterisk/asterisk-16.30.1.ebuild
@@ -19,7 +19,7 @@ IUSE_VOICEMAIL_STORAGE=(
voicemail_storage_odbc
voicemail_storage_imap
)
-IUSE="${IUSE_VOICEMAIL_STORAGE[*]} alsa blocks bluetooth calendar +caps cluster codec2 curl debug deprecated doc freetds gtalk http iconv ilbc ldap lua mysql newt odbc oss pjproject portaudio postgres radius selinux snmp span speex srtp +ssl static statsd syslog systemd unbound vorbis xmpp"
+IUSE="${IUSE_VOICEMAIL_STORAGE[*]} alsa blocks bluetooth calendar +caps cluster codec2 curl dahdi debug deprecated doc freetds gtalk http iconv ilbc ldap lua mysql newt odbc oss pjproject portaudio postgres radius selinux snmp span speex srtp +ssl static statsd syslog systemd unbound vorbis xmpp"
IUSE_EXPAND="VOICEMAIL_STORAGE"
REQUIRED_USE="gtalk? ( xmpp )
lua? ( ${LUA_REQUIRED_USE} )
@@ -55,6 +55,10 @@ DEPEND="acct-user/asterisk
cluster? ( sys-cluster/corosync )
codec2? ( media-libs/codec2:= )
curl? ( net-misc/curl )
+ dahdi? (
+ net-libs/libpri
+ net-misc/dahdi-tools
+ )
freetds? ( dev-db/freetds )
gtalk? ( dev-libs/iksemel )
http? ( dev-libs/gmime:2.6 )
@@ -228,9 +232,6 @@ src_configure() {
# Disable conversion tools (which fails to compile in some cases).
_menuselect --disable astdb2bdb menuselect.makeopts
- # dahdi isn't packaged anymore
- _menuselect --disable app_dahdiras app_meetme chan_dahdi codec_dahdi res_timing_dahdi
-
# The others are based on USE-flag settings
_use_select alsa chan_alsa
_use_select bluetooth chan_mobile
@@ -238,6 +239,7 @@ src_configure() {
_use_select cluster res_corosync
_use_select codec2 codec_codec2
_use_select curl func_curl res_config_curl res_curl
+ _use_select dahdi app_dahdiras app_meetme chan_dahdi codec_dahdi res_timing_dahdi
_use_select deprecated app_macro
_use_select freetds {cdr,cel}_tds
_use_select gtalk chan_motif
diff --git a/net-misc/asterisk/asterisk-18.17.0.ebuild b/net-misc/asterisk/asterisk-18.17.0.ebuild
index fd8ef65a8cbc..015737c8a097 100644
--- a/net-misc/asterisk/asterisk-18.17.0.ebuild
+++ b/net-misc/asterisk/asterisk-18.17.0.ebuild
@@ -18,7 +18,7 @@ IUSE_VOICEMAIL_STORAGE=(
voicemail_storage_odbc
voicemail_storage_imap
)
-IUSE="${IUSE_VOICEMAIL_STORAGE[*]} alsa blocks bluetooth calendar +caps cluster codec2 curl debug deprecated doc freetds gtalk http iconv ilbc ldap lua mysql newt odbc oss pjproject portaudio postgres radius selinux snmp span speex srtp +ssl static statsd syslog systemd unbound vorbis xmpp"
+IUSE="${IUSE_VOICEMAIL_STORAGE[*]} alsa blocks bluetooth calendar +caps cluster codec2 curl dahdi debug deprecated doc freetds gtalk http iconv ilbc ldap lua mysql newt odbc oss pjproject portaudio postgres radius selinux snmp span speex srtp +ssl static statsd syslog systemd unbound vorbis xmpp"
IUSE_EXPAND="VOICEMAIL_STORAGE"
REQUIRED_USE="gtalk? ( xmpp )
lua? ( ${LUA_REQUIRED_USE} )
@@ -52,6 +52,10 @@ DEPEND="acct-user/asterisk
cluster? ( sys-cluster/corosync )
codec2? ( media-libs/codec2:= )
curl? ( net-misc/curl )
+ dahdi? (
+ net-libs/libpri
+ net-misc/dahdi-tools
+ )
freetds? ( dev-db/freetds )
gtalk? ( dev-libs/iksemel )
http? ( dev-libs/gmime:2.6 )
@@ -223,9 +227,6 @@ src_configure() {
# Disable conversion tools (which fails to compile in some cases).
_menuselect --disable astdb2bdb menuselect.makeopts
- # dahdi isn't packaged anymore
- _menuselect --disable app_dahdiras app_meetme chan_dahdi codec_dahdi res_timing_dahdi
-
# The others are based on USE-flag settings
_use_select alsa chan_alsa
_use_select bluetooth chan_mobile
@@ -233,6 +234,7 @@ src_configure() {
_use_select cluster res_corosync
_use_select codec2 codec_codec2
_use_select curl func_curl res_config_curl res_curl
+ _use_select dahdi app_dahdiras app_meetme chan_dahdi codec_dahdi res_timing_dahdi
_use_select deprecated app_macro
_use_select freetds {cdr,cel}_tds
_use_select gtalk chan_motif
diff --git a/net-misc/asterisk/asterisk-18.18.0.ebuild b/net-misc/asterisk/asterisk-18.18.0.ebuild
index 8722283e039a..b2e2fa41bd6b 100644
--- a/net-misc/asterisk/asterisk-18.18.0.ebuild
+++ b/net-misc/asterisk/asterisk-18.18.0.ebuild
@@ -18,7 +18,7 @@ IUSE_VOICEMAIL_STORAGE=(
voicemail_storage_odbc
voicemail_storage_imap
)
-IUSE="${IUSE_VOICEMAIL_STORAGE[*]} alsa blocks bluetooth calendar +caps cluster codec2 curl debug deprecated doc freetds gtalk http iconv ilbc ldap lua mysql newt odbc oss pjproject portaudio postgres radius selinux snmp span speex srtp +ssl static statsd syslog systemd unbound vorbis xmpp"
+IUSE="${IUSE_VOICEMAIL_STORAGE[*]} alsa blocks bluetooth calendar +caps cluster codec2 curl dahdi debug deprecated doc freetds gtalk http iconv ilbc ldap lua mysql newt odbc oss pjproject portaudio postgres radius selinux snmp span speex srtp +ssl static statsd syslog systemd unbound vorbis xmpp"
IUSE_EXPAND="VOICEMAIL_STORAGE"
REQUIRED_USE="gtalk? ( xmpp )
lua? ( ${LUA_REQUIRED_USE} )
@@ -53,6 +53,10 @@ DEPEND="acct-user/asterisk
cluster? ( sys-cluster/corosync )
codec2? ( media-libs/codec2:= )
curl? ( net-misc/curl )
+ dahdi? (
+ net-libs/libpri
+ net-misc/dahdi-tools
+ )
freetds? ( dev-db/freetds )
gtalk? ( dev-libs/iksemel )
http? ( dev-libs/gmime:2.6 )
@@ -225,9 +229,6 @@ src_configure() {
# Disable conversion tools (which fails to compile in some cases).
_menuselect --disable astdb2bdb menuselect.makeopts
- # dahdi isn't packaged anymore
- _menuselect --disable app_dahdiras app_meetme chan_dahdi codec_dahdi res_timing_dahdi
-
# The others are based on USE-flag settings
_use_select alsa chan_alsa
_use_select bluetooth chan_mobile
@@ -235,6 +236,7 @@ src_configure() {
_use_select cluster res_corosync
_use_select codec2 codec_codec2
_use_select curl func_curl res_config_curl res_curl
+ _use_select dahdi app_dahdiras app_meetme chan_dahdi codec_dahdi res_timing_dahdi
_use_select deprecated app_macro
_use_select freetds {cdr,cel}_tds
_use_select gtalk chan_motif
diff --git a/net-misc/asterisk/asterisk-18.18.1.ebuild b/net-misc/asterisk/asterisk-18.18.1.ebuild
index 0042bf5f8af3..3f4247463485 100644
--- a/net-misc/asterisk/asterisk-18.18.1.ebuild
+++ b/net-misc/asterisk/asterisk-18.18.1.ebuild
@@ -18,7 +18,7 @@ IUSE_VOICEMAIL_STORAGE=(
voicemail_storage_odbc
voicemail_storage_imap
)
-IUSE="${IUSE_VOICEMAIL_STORAGE[*]} alsa blocks bluetooth calendar +caps cluster codec2 curl debug deprecated doc freetds gtalk http iconv ilbc ldap lua mysql newt odbc oss pjproject portaudio postgres radius selinux snmp span speex srtp +ssl static statsd syslog systemd unbound vorbis xmpp"
+IUSE="${IUSE_VOICEMAIL_STORAGE[*]} alsa blocks bluetooth calendar +caps cluster codec2 curl dahdi debug deprecated doc freetds gtalk http iconv ilbc ldap lua mysql newt odbc oss pjproject portaudio postgres radius selinux snmp span speex srtp +ssl static statsd syslog systemd unbound vorbis xmpp"
IUSE_EXPAND="VOICEMAIL_STORAGE"
REQUIRED_USE="gtalk? ( xmpp )
lua? ( ${LUA_REQUIRED_USE} )
@@ -53,6 +53,10 @@ DEPEND="acct-user/asterisk
cluster? ( sys-cluster/corosync )
codec2? ( media-libs/codec2:= )
curl? ( net-misc/curl )
+ dahdi? (
+ net-libs/libpri
+ net-misc/dahdi-tools
+ )
freetds? ( dev-db/freetds )
gtalk? ( dev-libs/iksemel )
http? ( dev-libs/gmime:2.6 )
@@ -226,9 +230,6 @@ src_configure() {
# Disable conversion tools (which fails to compile in some cases).
_menuselect --disable astdb2bdb menuselect.makeopts
- # dahdi isn't packaged anymore
- _menuselect --disable app_dahdiras app_meetme chan_dahdi codec_dahdi res_timing_dahdi
-
# The others are based on USE-flag settings
_use_select alsa chan_alsa
_use_select bluetooth chan_mobile
@@ -236,6 +237,7 @@ src_configure() {
_use_select cluster res_corosync
_use_select codec2 codec_codec2
_use_select curl func_curl res_config_curl res_curl
+ _use_select dahdi app_dahdiras app_meetme chan_dahdi codec_dahdi res_timing_dahdi
_use_select deprecated app_macro
_use_select freetds {cdr,cel}_tds
_use_select gtalk chan_motif
diff --git a/net-misc/asterisk/asterisk-20.3.0.ebuild b/net-misc/asterisk/asterisk-20.3.0.ebuild
index 4fd7205c33eb..e4e12e12fba8 100644
--- a/net-misc/asterisk/asterisk-20.3.0.ebuild
+++ b/net-misc/asterisk/asterisk-20.3.0.ebuild
@@ -18,7 +18,7 @@ IUSE_VOICEMAIL_STORAGE=(
voicemail_storage_odbc
voicemail_storage_imap
)
-IUSE="${IUSE_VOICEMAIL_STORAGE[*]} alsa blocks bluetooth calendar +caps cluster codec2 curl debug deprecated doc freetds gtalk http iconv ilbc ldap lua mysql newt odbc pjproject portaudio postgres radius selinux snmp span speex srtp +ssl static statsd systemd unbound vorbis xmpp"
+IUSE="${IUSE_VOICEMAIL_STORAGE[*]} alsa blocks bluetooth calendar +caps cluster codec2 curl dahdi debug deprecated doc freetds gtalk http iconv ilbc ldap lua mysql newt odbc pjproject portaudio postgres radius selinux snmp span speex srtp +ssl static statsd systemd unbound vorbis xmpp"
IUSE_EXPAND="VOICEMAIL_STORAGE"
REQUIRED_USE="gtalk? ( xmpp )
lua? ( ${LUA_REQUIRED_USE} )
@@ -53,6 +53,10 @@ DEPEND="acct-user/asterisk
cluster? ( sys-cluster/corosync )
codec2? ( media-libs/codec2:= )
curl? ( net-misc/curl )
+ dahdi? (
+ net-libs/libpri
+ net-misc/dahdi-tools
+ )
freetds? ( dev-db/freetds )
gtalk? ( dev-libs/iksemel )
http? ( dev-libs/gmime:2.6 )
@@ -223,9 +227,6 @@ src_configure() {
# Disable conversion tools (which fails to compile in some cases).
_menuselect --disable astdb2bdb menuselect.makeopts
- # dahdi isn't packaged anymore
- _menuselect --disable app_meetme chan_dahdi codec_dahdi res_timing_dahdi
-
# The others are based on USE-flag settings
_use_select alsa chan_alsa
_use_select bluetooth chan_mobile
@@ -233,6 +234,7 @@ src_configure() {
_use_select cluster res_corosync
_use_select codec2 codec_codec2
_use_select curl func_curl res_config_curl res_curl
+ _use_select dahdi app_meetme chan_dahdi codec_dahdi res_timing_dahdi
_use_select deprecated app_macro chan_sip res_monitor
_use_select freetds {cdr,cel}_tds
_use_select gtalk chan_motif
diff --git a/net-misc/asterisk/asterisk-20.3.1.ebuild b/net-misc/asterisk/asterisk-20.3.1.ebuild
index 46875841174f..080afa1dc8ea 100644
--- a/net-misc/asterisk/asterisk-20.3.1.ebuild
+++ b/net-misc/asterisk/asterisk-20.3.1.ebuild
@@ -18,7 +18,7 @@ IUSE_VOICEMAIL_STORAGE=(
voicemail_storage_odbc
voicemail_storage_imap
)
-IUSE="${IUSE_VOICEMAIL_STORAGE[*]} alsa blocks bluetooth calendar +caps cluster codec2 curl debug deprecated doc freetds gtalk http iconv ilbc ldap lua mysql newt odbc pjproject portaudio postgres radius selinux snmp span speex srtp +ssl static statsd systemd unbound vorbis xmpp"
+IUSE="${IUSE_VOICEMAIL_STORAGE[*]} alsa blocks bluetooth calendar +caps cluster codec2 curl dahdi debug deprecated doc freetds gtalk http iconv ilbc ldap lua mysql newt odbc pjproject portaudio postgres radius selinux snmp span speex srtp +ssl static statsd systemd unbound vorbis xmpp"
IUSE_EXPAND="VOICEMAIL_STORAGE"
REQUIRED_USE="gtalk? ( xmpp )
lua? ( ${LUA_REQUIRED_USE} )
@@ -53,6 +53,10 @@ DEPEND="acct-user/asterisk
cluster? ( sys-cluster/corosync )
codec2? ( media-libs/codec2:= )
curl? ( net-misc/curl )
+ dahdi? (
+ net-libs/libpri
+ net-misc/dahdi-tools
+ )
freetds? ( dev-db/freetds )
gtalk? ( dev-libs/iksemel )
http? ( dev-libs/gmime:2.6 )
@@ -224,9 +228,6 @@ src_configure() {
# Disable conversion tools (which fails to compile in some cases).
_menuselect --disable astdb2bdb menuselect.makeopts
- # dahdi isn't packaged anymore
- _menuselect --disable app_meetme chan_dahdi codec_dahdi res_timing_dahdi
-
# The others are based on USE-flag settings
_use_select alsa chan_alsa
_use_select bluetooth chan_mobile
@@ -234,6 +235,7 @@ src_configure() {
_use_select cluster res_corosync
_use_select codec2 codec_codec2
_use_select curl func_curl res_config_curl res_curl
+ _use_select dahdi app_meetme chan_dahdi codec_dahdi res_timing_dahdi
_use_select deprecated app_macro chan_sip res_monitor
_use_select freetds {cdr,cel}_tds
_use_select gtalk chan_motif
diff --git a/net-misc/asterisk/metadata.xml b/net-misc/asterisk/metadata.xml
index 7444210cb8ff..a24c794eaae3 100644
--- a/net-misc/asterisk/metadata.xml
+++ b/net-misc/asterisk/metadata.xml
@@ -13,6 +13,7 @@
<flag name="blocks">Utlize -fblocks (only supported by, and required when using, clang/LLVM)</flag>
<flag name="cluster">Enable high-availability support through the Corosync Cluster Engine</flag>
<flag name="codec2">Enable Codec2 support in asterisk</flag>
+ <flag name="dahdi">Support Digium compatible hardware (formerly known as Zaptel)</flag>
<flag name="deprecated">Enable deprecated features (eg, app_macro)</flag>
<flag name="gtalk">Enable support for Google Talk services</flag>
<flag name="http">Enable embedded web server</flag>
diff --git a/profiles/base/package.use.mask b/profiles/base/package.use.mask
index 04e74df9c396..22883b23c785 100644
--- a/profiles/base/package.use.mask
+++ b/profiles/base/package.use.mask
@@ -65,6 +65,11 @@ dev-haskell/scientific test
dev-haskell/splitmix test
dev-haskell/tasty-expected-failure test
+# Jaco Kroon <jaco@uls.co.za> (2023-09-19)
+# Joonas Niilola <juippis@gentoo.org> (2023-09-21)
+# DAHDI is being last-rited. See bug #914477.
+net-misc/asterisk dahdi
+
# Matt Turner <mattst88@gentoo.org> (2023-09-14)
# Not ported to libsoup:3.0
app-office/abiword collab