summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2023-11-25 17:36:32 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2023-11-25 17:36:32 +0100
commit71cfef685073b8533018c9c67dbd66a2b0d1b61d (patch)
tree55f9eec18c9099b949e3c88bcdbb1976d71ef7dc
parentdev-python/pygccxml: Drop empty line (diff)
downloadgentoo-71cfef685073b8533018c9c67dbd66a2b0d1b61d.tar.gz
gentoo-71cfef685073b8533018c9c67dbd66a2b0d1b61d.tar.bz2
gentoo-71cfef685073b8533018c9c67dbd66a2b0d1b61d.zip
media-radio/tucnak: add 4.52
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
-rw-r--r--media-radio/tucnak/Manifest1
-rw-r--r--media-radio/tucnak/tucnak-4.52.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/media-radio/tucnak/Manifest b/media-radio/tucnak/Manifest
index 569b05a5a819..45d355c18823 100644
--- a/media-radio/tucnak/Manifest
+++ b/media-radio/tucnak/Manifest
@@ -1,2 +1,3 @@
DIST tucnak-4.46.tar.gz 3617927 BLAKE2B 090a962c686e0de83d41c4fb017caaf9482d2058909164a97db4eb7e4bfd4d8fe19e21cc750f31493e4bf64454fa8d03f65b55da58749257601dba64b1476c8e SHA512 9c33c9dd7061d0ab2cb696ccf121145ebc60e0f8b2a29152ec6e59155af186c20d101cce698d48b8d669f64c8ee4b88d57d1896b574e9e250853a2bc45029d06
DIST tucnak-4.49.tar.gz 3619211 BLAKE2B 549399c2123ebd17f1164d431707b49a01159566be97b05b5f656a40c555d6c96b04a7d765db4ad94231f01b8d3af600a060104e42a87c60b6905eeba6cf8c8e SHA512 9c55b9a9048c95692d6cce7586c1b78a6237b02a43ad82ec771491f8463518f1e09e9f0be4db02b061b5aff518507a11bd6b0b7a038b90ff18ea1286accc3be4
+DIST tucnak-4.52.tar.gz 6684620 BLAKE2B c56949f61b8a0365deec0eab95d68067e5e8674164ad95f83c1b5cb84740af254f559c5158dc3aa8281353f4db2aee8163de1f92a08dc68487a8be0b00619e92 SHA512 bd20d94bc136e0078628b149f70e510027f9482fcdc881856ba13ed29a2c6be2e02c87c1d2fd2b670ecc347e1335378e5dd3aec5efa5db259b2730a13c10f019
diff --git a/media-radio/tucnak/tucnak-4.52.ebuild b/media-radio/tucnak/tucnak-4.52.ebuild
new file mode 100644
index 000000000000..da01abd9c6d1
--- /dev/null
+++ b/media-radio/tucnak/tucnak-4.52.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools flag-o-matic
+
+DESCRIPTION="Amateur Radio VHF Contest Logbook"
+HOMEPAGE="http://tucnak.nagano.cz"
+SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa fftw gpm hamlib suid"
+
+RDEPEND="dev-libs/glib:2
+ ~dev-libs/libzia-4.52
+ media-libs/libsndfile
+ media-libs/libsdl2
+ alsa? ( media-libs/alsa-lib )
+ fftw? ( sci-libs/fftw:3.0 )
+ gpm? ( sys-libs/gpm )
+ hamlib? ( media-libs/hamlib:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ eapply_user
+ # fix destop file
+ sed -i -e "s/HamRadio/HamRadio;/" share/applications/tucnak.desktop || die
+ # fix doc install path
+ sed -i -e "s/docsdir/# docsdir/" \
+ -e "s/docs_DATA =/# docs_DATA/" \
+ -e "s/EXTRA_DIST =/# EXTRA_DIST =/" Makefile.am doc/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -L/usr/$(get_libdir)/hamlib
+ econf $(use_with alsa) \
+ $(use_with gpm) $(use_with hamlib) \
+ $(use_with fftw fftw3)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog doc/NAVOD.pdf
+ if use suid ; then
+ fperms 4711 /usr/bin/soundwrapper
+ fi
+}
+
+pkg_postinst() {
+ elog "In order to use sound with tucnak add yourself to the 'audio' group"
+ elog "and to key your rig via the parport add yourself to the 'lp' group"
+ elog ""
+ elog "tucnak can be used with the following additional packages:"
+ elog " media-radio/cwdaemon : Morse output via code cwdaemon"
+ elog " (No need to recompile)"
+ if use suid ; then
+ ewarn "You have choosen to install the little helper program 'soundwrapper'"
+ ewarn "setuid by setting USE=suid. That helper is only needed if you"
+ ewarn "want to use morse sidetone output via the PC speaker."
+ ewarn ""
+ ewarn "While the helper should be safe by design be aware that setting"
+ ewarn "any program setuid is a security risk."
+ fi
+}