summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-17 14:01:50 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-17 14:07:18 +0100
commit71df18adbd3a43f0573bed44a76e2bb4792474c3 (patch)
tree15168d67eba473b5fc424834e78f67e1922c51ea
parentsys-power/acpi_call: add myself as maintainer (diff)
downloadgentoo-71df18adbd3a43f0573bed44a76e2bb4792474c3.tar.gz
gentoo-71df18adbd3a43f0573bed44a76e2bb4792474c3.tar.bz2
gentoo-71df18adbd3a43f0573bed44a76e2bb4792474c3.zip
sys-power/acpi_call: bump to version 1.2.1
Changes: * Correct license * Drop all patches, as merged by upstream. * Added examples Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--sys-power/acpi_call/Manifest1
-rw-r--r--sys-power/acpi_call/acpi_call-1.2.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-power/acpi_call/Manifest b/sys-power/acpi_call/Manifest
index 35e63fbb6c7c..8a5678808904 100644
--- a/sys-power/acpi_call/Manifest
+++ b/sys-power/acpi_call/Manifest
@@ -1,2 +1,3 @@
DIST acpi_call-1.1.0.tar.gz 10470 BLAKE2B 000c5e6f1eb968bdea3d8dfb6d6bf7b18daffe8baa75ff32e8c6c4b98cafe0a72a67a65a17994a1c8efa16f528bdfbf2b27686a146730c319a5195dfa9ec0d51 SHA512 d5cf13c15f9057e3a27aaacfee6dcdb17b6a79194bdc8fd57b8140c07a532e2e58151bea881aa158c1183ac3bbe89f83fcfc2279ffd9e945a72331b6ddbf2c70
+DIST acpi_call-1.2.1.tar.gz 12340 BLAKE2B e113f8c150c8e2f4f75ca1dd81cc4399f24bedcd716c9158561e8cb9f5e63e77cade18e6543ade4ec383690bf7041a583e297948789773db8ad9b63a957e61e8 SHA512 91553cf70a6b0173a6bfec38fcfb62ecd17614c91a888933704bb57d788592ce6981b01fb7c5e4bb8efdbe7fe229860c9f2be4b549dd71b232704c8bf0b3cfee
DIST acpi_call-3.17.tar.gz 10470 BLAKE2B e1a4912f4b92532aa8496e668541975b7e563dfd7613d41f33503d5eecad786b84ba98b205f27c4a4fbd3b37b034a467cf7c9a73f2995539d2117f50751df682 SHA512 39f8f924995ba4e5490e93f03c33db083ced224699b1028102294b2cc99edebd1eea04d33b50beed9dea86939c124682ef8d013c990d5611471b104be3200cb1
diff --git a/sys-power/acpi_call/acpi_call-1.2.1.ebuild b/sys-power/acpi_call/acpi_call-1.2.1.ebuild
new file mode 100644
index 000000000000..781cbf2fc3af
--- /dev/null
+++ b/sys-power/acpi_call/acpi_call-1.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info linux-mod
+
+DESCRIPTION="A linux kernel module that enables calls to ACPI"
+HOMEPAGE="https://github.com/nix-community/acpi_call"
+SRC_URI="https://github.com/nix-community/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+BUILD_TARGETS="default"
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+
+src_compile() {
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+
+ if use examples; then
+ insinto /usr/share/acpi_call
+ doins examples/*.sh
+ fi
+}