summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-08-18 19:52:45 -0700
committerMatt Turner <mattst88@gentoo.org>2021-08-18 20:01:39 -0700
commit71f9ed120a8fd60fb46dfce8d246167c7006c56a (patch)
tree31965e23e65ffc77360884e3ff99dd77b5f1499a
parentgnome-base/gnome-shell: Version bump to 40.4 (diff)
downloadgentoo-71f9ed12.tar.gz
gentoo-71f9ed12.tar.bz2
gentoo-71f9ed12.zip
gnome-extra/gnome-shell-extensions: Version bump to 40.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-extra/gnome-shell-extensions/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extensions/gnome-shell-extensions-40.4.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extensions/Manifest b/gnome-extra/gnome-shell-extensions/Manifest
index 4ce782cfaa48..6a132a525002 100644
--- a/gnome-extra/gnome-shell-extensions/Manifest
+++ b/gnome-extra/gnome-shell-extensions/Manifest
@@ -1,2 +1,3 @@
DIST gnome-shell-extensions-40.2.tar.xz 218032 BLAKE2B f4b8daf2fcd62eaef0ad0960c930fc9368bd426b867a31351b39a2a628dfe9c0631419a5f067b4ac1eb03d2df931ba3a8ea99d4e72043459463b86eb00f6787b SHA512 f02a02a8410e77e8c8b0a764bb7949727974e9a4c0125ac2b6e68c1b20b663ef2de82ddaaed882dd5ffb3a6fd9898b372b6201d53da33f11677c32e82272d2aa
DIST gnome-shell-extensions-40.3.tar.xz 218108 BLAKE2B 33174ef4c80caf375d48f11b7678ec78bfbe60a9d4456e21856b09a0a83e99ee7b68598c719a6913a29d9686317015fbc8d8bfae856e433414889e59e82e5ca3 SHA512 3773b0a5ec81b6663a3b2c5f5d1f8e7619fdba49ce67b25ee0f5555d17ea7c9740c3698b7a4e4f7fa78241c8738663c602cb5ed1ff9874b8ad2321fec0dbc737
+DIST gnome-shell-extensions-40.4.tar.xz 218088 BLAKE2B f992c98fa5ceec84c774881468e0c9736d24f1834b9d6976f7cddc2dce455393fad0ad055c1e02b308135914029874c4d87d3a09733a7b4686308e9052cef21a SHA512 79f087c9fbc7764241751441190819b3e768530257ffe3a7b39b1004f8997de9c8ea381338ec0544a39b8cc6866137d315e56f3f058c9b66a9ed566ec40712ef
diff --git a/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-40.4.ebuild b/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-40.4.ebuild
new file mode 100644
index 000000000000..f5bc021adcaa
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-40.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org readme.gentoo-r1 meson xdg
+
+DESCRIPTION="JavaScript extensions for GNOME Shell"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell/Extensions"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.26:2
+ >=gnome-base/libgtop-2.28.3[introspection]
+ >=app-eselect/eselect-gnome-shell-extensions-20111211
+"
+RDEPEND="${DEPEND}
+ >=dev-libs/gjs-1.29
+ dev-libs/gobject-introspection:=
+ dev-libs/atk[introspection]
+ gnome-base/gnome-menus:3[introspection]
+ =gnome-base/gnome-shell-$(ver_cut 1-2)*
+ media-libs/clutter:1.0[introspection]
+ net-libs/telepathy-glib[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/adwaita-icon-theme
+ >=x11-wm/mutter-3.32[introspection]
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Installed extensions installed are initially disabled by default.
+To change the system default and enable some extensions, you can use
+# eselect gnome-shell-extensions
+
+Alternatively, to enable/disable extensions on a per-user basis,
+you can use the https://extensions.gnome.org/ web interface, the
+gnome-extra/gnome-tweaks GUI, or modify the org.gnome.shell
+enabled-extensions gsettings key from the command line or a script."
+
+src_configure() {
+ meson_src_configure \
+ -Dextension_set=all \
+ -Dclassic_mode=true
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+
+ readme.gentoo_print_elog
+}